summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-27 06:13:43 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-27 06:13:43 +0000
commit4c56fccdf92146c5f56a501b9571aff49415e39a (patch)
treec9d439071f249c2e4e4684a90a8eea21fa51efc9 /dev-ruby/locale
parentAdd revision bump compatible with rake 10 and ruby20. (diff)
downloadgentoo-2-4c56fccdf92146c5f56a501b9571aff49415e39a.tar.gz
gentoo-2-4c56fccdf92146c5f56a501b9571aff49415e39a.tar.bz2
gentoo-2-4c56fccdf92146c5f56a501b9571aff49415e39a.zip
Add revision bump to create a stable candidate.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/locale')
-rw-r--r--dev-ruby/locale/ChangeLog8
-rw-r--r--dev-ruby/locale/locale-2.1.0-r1.ebuild4
-rw-r--r--dev-ruby/locale/locale-2.1.0-r2.ebuild63
3 files changed, 72 insertions, 3 deletions
diff --git a/dev-ruby/locale/ChangeLog b/dev-ruby/locale/ChangeLog
index de3b086133e7..20a0d27514fa 100644
--- a/dev-ruby/locale/ChangeLog
+++ b/dev-ruby/locale/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/locale
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/ChangeLog,v 1.60 2014/05/27 06:01:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/ChangeLog,v 1.61 2014/05/27 06:13:43 graaff Exp $
+
+*locale-2.1.0-r2 (27 May 2014)
+
+ 27 May 2014; Hans de Graaff <graaff@gentoo.org> locale-2.1.0-r1.ebuild,
+ +locale-2.1.0-r2.ebuild:
+ Add revision bump to create a stable candidate.
*locale-2.0.5-r4 (27 May 2014)
diff --git a/dev-ruby/locale/locale-2.1.0-r1.ebuild b/dev-ruby/locale/locale-2.1.0-r1.ebuild
index 030dc41db249..af0674cdd6f8 100644
--- a/dev-ruby/locale/locale-2.1.0-r1.ebuild
+++ b/dev-ruby/locale/locale-2.1.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.1.0-r1.ebuild,v 1.4 2014/05/16 18:14:39 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.1.0-r1.ebuild,v 1.5 2014/05/27 06:13:43 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 jruby"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR="doc/reference"
diff --git a/dev-ruby/locale/locale-2.1.0-r2.ebuild b/dev-ruby/locale/locale-2.1.0-r2.ebuild
new file mode 100644
index 000000000000..c1727fdf45c3
--- /dev/null
+++ b/dev-ruby/locale/locale-2.1.0-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.1.0-r2.ebuild,v 1.1 2014/05/27 06:13:43 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc/reference"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc doc/text/news.md"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby library which provides basic APIs for localization."
+HOMEPAGE="https://github.com/ruby-gettext/locale"
+LICENSE="|| ( Ruby GPL-2 )"
+SRC_URI="https://github.com/ruby-gettext/locale/archive/${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/test-unit-rr )"
+
+all_ruby_prepare() {
+ sed -i -e '/notify/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid failing tests in the partial jruby
+ # implementation. This may be dependeny on the specific
+ # locales available or it may be an issue with Gentoo still
+ # using jruby 1.6.
+ sed -i -e '/test_locales/,/end/ s:^:#:' test/test_driver_jruby.rb || die
+ ;;
+ esac
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples || die
+}