summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-17 06:53:15 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-17 06:53:15 +0000
commit71677234bf02ee917865891754bfb02d4730048b (patch)
treebf979acfc0415f18fee97a6352c92eeaacfe8605 /dev-ruby/libxml
parent[bump] dev-perl/Devel-Size-0.730.0 (diff)
downloadgentoo-2-71677234bf02ee917865891754bfb02d4730048b.tar.gz
gentoo-2-71677234bf02ee917865891754bfb02d4730048b.tar.bz2
gentoo-2-71677234bf02ee917865891754bfb02d4730048b.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/ChangeLog9
-rw-r--r--dev-ruby/libxml/libxml-2.0.0.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index 52680a801db7..2aac285e09cd 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/libxml
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.32 2010/06/05 11:37:01 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.33 2011/04/17 06:53:15 graaff Exp $
+
+*libxml-2.0.0 (17 Apr 2011)
+
+ 17 Apr 2011; Hans de Graaff <graaff@gentoo.org> +libxml-2.0.0.ebuild:
+ Version bump.
*libxml-1.1.4 (05 Jun 2010)
diff --git a/dev-ruby/libxml/libxml-2.0.0.ebuild b/dev-ruby/libxml/libxml-2.0.0.ebuild
new file mode 100644
index 000000000000..369723bee667
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.0.0.ebuild,v 1.1 2011/04/17 06:53:15 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}