summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-29 18:28:38 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-29 18:28:38 +0000
commitcf34b54d810d51add04d9dd65090b6f0f9c7a05d (patch)
tree02033c62c11897bf17f2ea3561c14a19cf96604c /dev-ruby/kramdown
parentSecurity bump (bug #471694). (diff)
downloadgentoo-2-cf34b54d810d51add04d9dd65090b6f0f9c7a05d.tar.gz
gentoo-2-cf34b54d810d51add04d9dd65090b6f0f9c7a05d.tar.bz2
gentoo-2-cf34b54d810d51add04d9dd65090b6f0f9c7a05d.zip
Version bump, thanks to mrueg in the ruby overlay.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/ChangeLog7
-rw-r--r--dev-ruby/kramdown/kramdown-1.0.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/kramdown/ChangeLog b/dev-ruby/kramdown/ChangeLog
index b469bfacb5e1..d7220246e287 100644
--- a/dev-ruby/kramdown/ChangeLog
+++ b/dev-ruby/kramdown/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/kramdown
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.21 2013/05/05 06:09:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.22 2013/05/29 18:28:38 graaff Exp $
+
+*kramdown-1.0.2 (29 May 2013)
+
+ 29 May 2013; Hans de Graaff <graaff@gentoo.org> +kramdown-1.0.2.ebuild:
+ Version bump, thanks to mrueg in the ruby overlay.
05 May 2013; Hans de Graaff <graaff@gentoo.org> -kramdown-0.14.1.ebuild:
Cleanup.
diff --git a/dev-ruby/kramdown/kramdown-1.0.2.ebuild b/dev-ruby/kramdown/kramdown-1.0.2.ebuild
new file mode 100644
index 000000000000..e64625e36889
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-1.0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/kramdown-1.0.2.ebuild,v 1.1 2013/05/29 18:28:38 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using a strict syntax definition"
+HOMEPAGE="http://kramdown.rubyforge.org/"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/coderay-1.0.0
+ >=dev-ruby/stringex-1.5.1 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}