summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-08-24 05:04:21 +0000
committerHans de Graaff <graaff@gentoo.org>2014-08-24 05:04:21 +0000
commit501372f62246d937f959edc86994d6a58fca5125 (patch)
tree34905d4d90eee2faf386a0319678b88fc57960b2 /dev-ruby/inifile
parentVersion bump. (diff)
downloadgentoo-2-501372f62246d937f959edc86994d6a58fca5125.tar.gz
gentoo-2-501372f62246d937f959edc86994d6a58fca5125.tar.bz2
gentoo-2-501372f62246d937f959edc86994d6a58fca5125.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/inifile')
-rw-r--r--dev-ruby/inifile/ChangeLog7
-rw-r--r--dev-ruby/inifile/inifile-3.0.0.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/inifile/ChangeLog b/dev-ruby/inifile/ChangeLog
index 27f34778f1e1..1ddab653124a 100644
--- a/dev-ruby/inifile/ChangeLog
+++ b/dev-ruby/inifile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/inifile
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/inifile/ChangeLog,v 1.9 2014/08/13 01:43:51 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/inifile/ChangeLog,v 1.10 2014/08/24 05:04:21 graaff Exp $
+
+*inifile-3.0.0 (24 Aug 2014)
+
+ 24 Aug 2014; Hans de Graaff <graaff@gentoo.org> +inifile-3.0.0.ebuild:
+ Version bump.
13 Aug 2014; Manuel Rüger <mrueg@gentoo.org> inifile-2.0.2-r1.ebuild:
Add ruby21 support.
diff --git a/dev-ruby/inifile/inifile-3.0.0.ebuild b/dev-ruby/inifile/inifile-3.0.0.ebuild
new file mode 100644
index 000000000000..4d0bc6037712
--- /dev/null
+++ b/dev-ruby/inifile/inifile-3.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/inifile/inifile-3.0.0.ebuild,v 1.1 2014/08/24 05:04:21 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Native Ruby package for reading and writing INI files"
+HOMEPAGE="https://github.com/TwP/inifile"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -S testrb test/test_*.rb || die
+}