summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-08-31 17:50:17 +0000
committerAlex Legler <a3li@gentoo.org>2010-08-31 17:50:17 +0000
commitddc3bc5bfbabf611850de2ae1a5e93d50e4c051b (patch)
treef7883503f2b1e5d414021ea690d5417605506d71 /dev-ruby/i18n
parentVersion bump. (diff)
downloadgentoo-2-ddc3bc5bfbabf611850de2ae1a5e93d50e4c051b.tar.gz
gentoo-2-ddc3bc5bfbabf611850de2ae1a5e93d50e4c051b.tar.bz2
gentoo-2-ddc3bc5bfbabf611850de2ae1a5e93d50e4c051b.zip
Version bump. Tests run fine on ruby18 and ree18 without the gentoo patch now.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/i18n')
-rw-r--r--dev-ruby/i18n/ChangeLog8
-rw-r--r--dev-ruby/i18n/i18n-0.4.1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index 7c759e276897..6627daae8bdf 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.16 2010/07/29 00:12:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.17 2010/08/31 17:50:17 a3li Exp $
+
+*i18n-0.4.1 (31 Aug 2010)
+
+ 31 Aug 2010; Alex Legler <a3li@gentoo.org> +i18n-0.4.1.ebuild:
+ Version bump. Tests run fine on ruby18 and ree18 without the gentoo patch
+ now.
29 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org> i18n-0.1.3.ebuild,
i18n-0.3.3.ebuild, i18n-0.3.7.ebuild:
diff --git a/dev-ruby/i18n/i18n-0.4.1.ebuild b/dev-ruby/i18n/i18n-0.4.1.ebuild
new file mode 100644
index 000000000000..edb7a8d8a297
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.4.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.4.1.ebuild,v 1.1 2010/08/31 17:50:17 a3li Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 jruby ree18"
+
+# doc regeneration seem to need Jeweler, which is not currently
+# available
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile CHANGELOG.textile"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+SRC_URI="http://github.com/svenfuchs/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/svenfuchs-${PN}-*"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Optionally, the testsuite uses the activerecord gem to run some
+# tests; whent hey run, they require sqlite3-ruby, and that is not
+# available on JRuby.
+USE_RUBY="${USE_RUBY/jruby/}" \
+ ruby_add_bdepend "
+ test? (
+ dev-ruby/activerecord
+ dev-ruby/sqlite3-ruby
+ dev-ruby/ruby2ruby
+ )"
+
+# mocha is optionally used by the testsuite, try to increase coverage
+# of testing by depending on it; when mocha is used, though,
+# test-unit:2 cannot be merged at the same time (mocha problem?)
+#
+# One further test dependency would be ruby-cldr
+# (http://rubygems.org/gems/ruby-cldr) but we don't have it in tree
+# yet.
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ !!dev-ruby/test-unit:2
+ )"
+
+src_compile() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_compile
+}
+
+src_test() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}