summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-19 07:46:35 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-19 07:46:35 +0000
commitac672df1ed21e2b31444758dc05fe1bd129b1835 (patch)
treecea15aa943d67df31c998f0ab2440112df607a4f /dev-ruby/hoe
parentClarify description of wide-int flag. Rename toolkit option to lucid. (diff)
downloadgentoo-2-ac672df1ed21e2b31444758dc05fe1bd129b1835.tar.gz
gentoo-2-ac672df1ed21e2b31444758dc05fe1bd129b1835.tar.bz2
gentoo-2-ac672df1ed21e2b31444758dc05fe1bd129b1835.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/hoe')
-rw-r--r--dev-ruby/hoe/ChangeLog8
-rw-r--r--dev-ruby/hoe/files/hoe-2.10.0-test-fix.patch23
-rw-r--r--dev-ruby/hoe/hoe-2.10.0.ebuild39
3 files changed, 69 insertions, 1 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index 6a2be2ba94b2..24a3a1214aa9 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.116 2011/07/15 17:29:03 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.117 2011/07/19 07:46:35 graaff Exp $
+
+*hoe-2.10.0 (19 Jul 2011)
+
+ 19 Jul 2011; Hans de Graaff <graaff@gentoo.org> +hoe-2.10.0.ebuild,
+ +files/hoe-2.10.0-test-fix.patch:
+ Version bump.
15 Jul 2011; Matt Turner <mattst88@gentoo.org> hoe-2.9.1.ebuild:
Added ~mips, bug 332593
diff --git a/dev-ruby/hoe/files/hoe-2.10.0-test-fix.patch b/dev-ruby/hoe/files/hoe-2.10.0-test-fix.patch
new file mode 100644
index 000000000000..62789de38eb9
--- /dev/null
+++ b/dev-ruby/hoe/files/hoe-2.10.0-test-fix.patch
@@ -0,0 +1,23 @@
+http://rubyforge.org/tracker/?func=detail&atid=5923&aid=29320&group_id=1513
+
+diff --git a/test/test_hoe_test.rb b/test/test_hoe_test.rb
+index 8a9e613..01dc0af 100644
+--- a/test/test_hoe_test.rb
++++ b/test/test_hoe_test.rb
+@@ -13,15 +13,13 @@ class TestHoeTest < MiniTest::Unit::TestCase
+ initialize_test
+
+ def test_globs
+- ['test/**/test_*.rb']
++ ['test/test_hoe_test.rb']
+ end
+ end
+ end
+
+ def test_make_test_cmd_with_different_testlibs
+ expected = ['-w -Ilib:bin:test:. -e \'require "rubygems"; %s',
+- 'require "test/test_hoe.rb"; ',
+- 'require "test/test_hoe_gemcutter.rb"; ',
+ 'require "test/test_hoe_test.rb"',
+ "' -- ",
+ ].join
diff --git a/dev-ruby/hoe/hoe-2.10.0.ebuild b/dev-ruby/hoe/hoe-2.10.0.ebuild
new file mode 100644
index 000000000000..b93e357b678c
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.10.0.ebuild,v 1.1 2011/07/19 07:46:35 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${P}-test-fix.patch" )
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend "test? ( dev-ruby/minitest >=dev-ruby/rubyforge-2.0.4 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"
+
+all_ruby_prepare() {
+ # Make test regexp more lenient to cover the way we name the binaries.
+ sed -i -e 's/sudo gem/sudo .?gem/' -e 's/\^gem/^.?gem/' test/test_hoe.rb || die
+}