summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-12-19 21:55:08 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-12-19 21:55:08 +0000
commitd95fdffd0a9ba5062a23fa46b4127150cb77720f (patch)
tree89718bd32eb9d0e4cc40aab856c7ad008d605620 /dev-ruby/hiera
parentNew ebuild for x11-apps/radeontop, utility to view Radeon GPU utilization; fi... (diff)
downloadgentoo-2-d95fdffd0a9ba5062a23fa46b4127150cb77720f.tar.gz
gentoo-2-d95fdffd0a9ba5062a23fa46b4127150cb77720f.tar.bz2
gentoo-2-d95fdffd0a9ba5062a23fa46b4127150cb77720f.zip
adding hiera 1.3.0
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-ruby/hiera')
-rw-r--r--dev-ruby/hiera/ChangeLog7
-rw-r--r--dev-ruby/hiera/hiera-1.3.0.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/hiera/ChangeLog b/dev-ruby/hiera/ChangeLog
index ebca58e67335..fd743c694941 100644
--- a/dev-ruby/hiera/ChangeLog
+++ b/dev-ruby/hiera/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hiera
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hiera/ChangeLog,v 1.14 2013/11/19 10:05:45 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hiera/ChangeLog,v 1.15 2013/12/19 21:55:08 prometheanfire Exp $
+
+*hiera-1.3.0 (19 Dec 2013)
+
+ 19 Dec 2013; Matthew Thode <prometheanfire@gentoo.org> +hiera-1.3.0.ebuild:
+ adding hiera 1.3.0
19 Nov 2013; Chema Alonso <nimiux@gentoo.org> hiera-1.2.1.ebuild:
Stable for amd64 wrt bug #486002
diff --git a/dev-ruby/hiera/hiera-1.3.0.ebuild b/dev-ruby/hiera/hiera-1.3.0.ebuild
new file mode 100644
index 000000000000..eb1e9d76e8f2
--- /dev/null
+++ b/dev-ruby/hiera/hiera-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hiera/hiera-1.3.0.ebuild,v 1.1 2013/12/19 21:55:08 prometheanfire Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="http://projects.puppetlabs.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/json"
+
+all_ruby_prepare() {
+ # Our json package is either the compiled version or the pure
+ # version. Fix gemspec accordingly.
+ sed -i -e 's/json_pure/json/' ../metadata || die
+}