summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-12 20:23:45 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-12 20:23:45 +0000
commit224c92001872f52765fddbbdc8bb6c84bed72646 (patch)
tree290dd1f1090ffe2a959a0b2b5a5def3ee7405350 /dev-ruby/gherkin
parentDisable static libraries and remove the .la files, the package does not expor... (diff)
downloadgentoo-2-224c92001872f52765fddbbdc8bb6c84bed72646.tar.gz
gentoo-2-224c92001872f52765fddbbdc8bb6c84bed72646.tar.bz2
gentoo-2-224c92001872f52765fddbbdc8bb6c84bed72646.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/ChangeLog9
-rw-r--r--dev-ruby/gherkin/gherkin-2.3.5.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 77769eb7b35a..c97df052fec2 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gherkin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.16 2010/12/28 08:35:28 grobian Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.17 2011/04/12 20:23:45 graaff Exp $
+
+*gherkin-2.3.5 (12 Apr 2011)
+
+ 12 Apr 2011; Hans de Graaff <graaff@gentoo.org> +gherkin-2.3.5.ebuild:
+ Version bump.
04 Dec 2010; Fabian Groffen <grobian@gentoo.org> gherkin-1.0.30-r1.ebuild:
Added Prefix keywords
diff --git a/dev-ruby/gherkin/gherkin-2.3.5.ebuild b/dev-ruby/gherkin/gherkin-2.3.5.ebuild
new file mode 100644
index 000000000000..2b876e982ecc
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.3.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.3.5.ebuild,v 1.1 2011/04/12 20:23:45 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
+HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/aslakhellesoy/gherkin/tarball/v${PV} -> ${P}.tgz"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+
+S="${WORKDIR}/aslakhellesoy-gherkin-*"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/awesome_print-0.3
+ >=dev-ruby/builder-3.0.0
+ >=dev-util/cucumber-0.10.0
+ >=dev-ruby/rspec-2.5.0
+ >=dev-ruby/term-ansicolor-1.0.5
+ )"
+
+ruby_add_rdepend ">=dev-ruby/json-1.4.6"
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Remove feature that depends on direct access to the cucumber
+ # source We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove this tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet.
+ if ! use test ; then
+ rm tasks/cucumber.rake || die "Unable to remove cucumber tasks."
+ fi
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ rdoc || die "Unable to generate documentation."
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" ${RUBY} -S rake cucumber || die "Cucumber features failed"
+}