summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-05 09:17:28 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-05 09:17:28 +0000
commitbf29c78ed324a8010ee768777e4013b966b9451e (patch)
treeaff97fd4cf8df0478b217d615c8416ce18c329e9 /dev-ruby/ffi
parentVirtual to be able to request a version of the ruby interpreter with threads ... (diff)
downloadgentoo-2-bf29c78ed324a8010ee768777e4013b966b9451e.tar.gz
gentoo-2-bf29c78ed324a8010ee768777e4013b966b9451e.tar.bz2
gentoo-2-bf29c78ed324a8010ee768777e4013b966b9451e.zip
Version bump. Depend on virtual/ruby-threads to ensure that the ruby interpreter has threading. Add back ree18.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ffi')
-rw-r--r--dev-ruby/ffi/ChangeLog8
-rw-r--r--dev-ruby/ffi/ffi-1.0.9.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ruby/ffi/ChangeLog b/dev-ruby/ffi/ChangeLog
index 2f16979e4377..ff3bf27a475d 100644
--- a/dev-ruby/ffi/ChangeLog
+++ b/dev-ruby/ffi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ffi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.16 2011/05/02 18:12:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.17 2011/06/05 09:17:28 graaff Exp $
+
+*ffi-1.0.9 (05 Jun 2011)
+
+ 05 Jun 2011; Hans de Graaff <graaff@gentoo.org> +ffi-1.0.9.ebuild:
+ Version bump. Depend on virtual/ruby-threads to ensure that the ruby
+ interpreter has threading. Add back ree18.
*ffi-1.0.7 (02 May 2011)
diff --git a/dev-ruby/ffi/ffi-1.0.9.ebuild b/dev-ruby/ffi/ffi-1.0.9.ebuild
new file mode 100644
index 000000000000..38b6ab15a75c
--- /dev/null
+++ b/dev-ruby/ffi/ffi-1.0.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ffi-1.0.9.ebuild,v 1.1 2011/06/05 09:17:28 graaff Exp $
+
+EAPI=4
+
+# jruby → unneeded, this is part of the standard JRuby distribution, and
+# would just install a dummy.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
+HOMEPAGE="http://wiki.github.com/ffi/ffi"
+
+SRC_URI="http://github.com/${PN}/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/${PN}-${PN}-*"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+RDEPEND="${RDEPEND} dev-libs/libffi"
+DEPEND="${DEPEND} dev-libs/libffi"
+
+ruby_add_bdepend dev-ruby/rake-compiler
+
+ruby_add_rdepend "virtual/ruby-threads"
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "compile failed"
+ ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}