summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-30 05:47:36 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-30 05:47:36 +0000
commita98bd85f111063957fc0fa72a29f4d74f3d75688 (patch)
treee3f12d25805083cc360f871906ea138f338bb781 /dev-ruby/ffi
parentWhitespace (diff)
downloadgentoo-2-a98bd85f111063957fc0fa72a29f4d74f3d75688.tar.gz
gentoo-2-a98bd85f111063957fc0fa72a29f4d74f3d75688.tar.bz2
gentoo-2-a98bd85f111063957fc0fa72a29f4d74f3d75688.zip
Version bump. Switched from LGPL to BSD.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ffi')
-rw-r--r--dev-ruby/ffi/ChangeLog7
-rw-r--r--dev-ruby/ffi/ffi-1.9.2.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ruby/ffi/ChangeLog b/dev-ruby/ffi/ChangeLog
index 322eb2166e2e..2cc81332384c 100644
--- a/dev-ruby/ffi/ChangeLog
+++ b/dev-ruby/ffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ffi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.52 2013/10/29 15:55:55 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.53 2013/10/30 05:47:36 mrueg Exp $
+
+*ffi-1.9.2 (30 Oct 2013)
+
+ 30 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +ffi-1.9.2.ebuild:
+ Version bump. Switched from LGPL to BSD.
*ffi-1.9.1 (29 Oct 2013)
diff --git a/dev-ruby/ffi/ffi-1.9.2.ebuild b/dev-ruby/ffi/ffi-1.9.2.ebuild
new file mode 100644
index 000000000000..148eeadf2f66
--- /dev/null
+++ b/dev-ruby/ffi/ffi-1.9.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ffi-1.9.2.ebuild,v 1.1 2013/10/30 05:47:36 mrueg Exp $
+
+EAPI=5
+
+# jruby → unneeded, this is part of the standard JRuby distribution, and
+# would just install a dummy.
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST="specs"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
+HOMEPAGE="http://wiki.github.com/ffi/ffi"
+
+SRC_URI="http://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+RDEPEND+=" virtual/libffi"
+DEPEND+=" virtual/libffi"
+
+ruby_add_bdepend "dev-ruby/rake-compiler dev-ruby/yard
+ test? ( dev-ruby/rspec:2 )"
+
+ruby_add_rdepend "virtual/ruby-threads"
+
+all_ruby_prepare() {
+ sed -i -e '/tasks/ s:^:#:' \
+ -e '/Gem::Tasks/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "compile failed"
+ ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}