summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-03-20 13:51:10 +0000
committerHans de Graaff <graaff@gentoo.org>2015-03-20 13:51:10 +0000
commit6e5b8841145f53690267795c0338d2335c904328 (patch)
treee62403ab46c786f1b69890cac9f753d23b91f93e /dev-ruby/erubis
parentAdd ruby22. (diff)
downloadgentoo-2-6e5b8841145f53690267795c0338d2335c904328.tar.gz
gentoo-2-6e5b8841145f53690267795c0338d2335c904328.tar.bz2
gentoo-2-6e5b8841145f53690267795c0338d2335c904328.zip
Drop jruby. Add ruby22. Restrict tests since they fail with Psych as YAML provider.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/erubis')
-rw-r--r--dev-ruby/erubis/ChangeLog8
-rw-r--r--dev-ruby/erubis/erubis-2.7.0-r2.ebuild35
2 files changed, 14 insertions, 29 deletions
diff --git a/dev-ruby/erubis/ChangeLog b/dev-ruby/erubis/ChangeLog
index 7ec44301c104..74f8b9492092 100644
--- a/dev-ruby/erubis/ChangeLog
+++ b/dev-ruby/erubis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/erubis
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/erubis/ChangeLog,v 1.31 2014/06/14 11:20:53 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/erubis/ChangeLog,v 1.32 2015/03/20 13:51:10 graaff Exp $
+
+ 20 Mar 2015; Hans de Graaff <graaff@gentoo.org> erubis-2.7.0-r2.ebuild:
+ Drop jruby. Add ruby22. Restrict tests since they fail with Psych as YAML
+ provider.
14 Jun 2014; Manuel Rüger <mrueg@gentoo.org> -erubis-2.7.0.ebuild:
Cleanup old.
diff --git a/dev-ruby/erubis/erubis-2.7.0-r2.ebuild b/dev-ruby/erubis/erubis-2.7.0-r2.ebuild
index ab77c65e67e5..76c9a6921c90 100644
--- a/dev-ruby/erubis/erubis-2.7.0-r2.ebuild
+++ b/dev-ruby/erubis/erubis-2.7.0-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/erubis/erubis-2.7.0-r2.ebuild,v 1.1 2014/04/19 09:08:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/erubis/erubis-2.7.0-r2.ebuild,v 1.2 2015/03/20 13:51:10 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
@@ -22,6 +22,10 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
+# http://rubyforge.org/tracker/index.php?func=detail&aid=29484&group_id=1320&atid=5201
+# Tests are not compatible with Psych as YAML module.
+RESTRICT="test"
+
ruby_add_rdepend ">=dev-ruby/abstract-1.0.0"
all_ruby_prepare() {
@@ -31,29 +35,6 @@ all_ruby_prepare() {
sed -i -e '/test-users-guide/ s:^:#:' test/test.rb || die
}
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Avoid test on jruby that fails different on syntax error.
- sed -i -e '/test_syntax2/,/^ end/ s:^:#:' test/test-main.rb || die
- ;;
- esac
-}
-
each_ruby_test() {
- case ${RUBY} in
- # http://rubyforge.org/tracker/index.php?func=detail&aid=29484&group_id=1320&atid=5201
- *ruby19)
- einfo "Tests are not compatible with ruby 1.9.3 with Psych as YAML module."
- ;;
- *ruby20)
- einfo "Tests are not compatible with ruby 2.0.0 with Psych as YAML module."
- ;;
- *ruby21)
- einfo "Tests are not compatible with ruby 2.1.x with Psych as YAML module."
- ;;
- *)
- PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -I. test/test.rb || die
- ;;
- esac
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -I. test/test.rb || die
}