summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-14 06:57:01 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-14 06:57:01 +0000
commitf1bd49df5629d31fad8a94be16d25df4f8e2bc8e (patch)
tree12a3d35efa0969dc1696c34b5d6e66f529b0ca76 /dev-ruby/daemon_controller
parentVersion bump. (diff)
downloadgentoo-2-f1bd49df5629d31fad8a94be16d25df4f8e2bc8e.tar.gz
gentoo-2-f1bd49df5629d31fad8a94be16d25df4f8e2bc8e.tar.bz2
gentoo-2-f1bd49df5629d31fad8a94be16d25df4f8e2bc8e.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/daemon_controller')
-rw-r--r--dev-ruby/daemon_controller/ChangeLog8
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.1.4.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/daemon_controller/ChangeLog b/dev-ruby/daemon_controller/ChangeLog
index 6789f84524e5..94bc34d4fad1 100644
--- a/dev-ruby/daemon_controller/ChangeLog
+++ b/dev-ruby/daemon_controller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/daemon_controller
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.20 2013/04/30 06:37:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.21 2013/07/14 06:57:01 graaff Exp $
+
+*daemon_controller-1.1.4 (14 Jul 2013)
+
+ 14 Jul 2013; Hans de Graaff <graaff@gentoo.org>
+ +daemon_controller-1.1.4.ebuild:
+ Version bump.
*daemon_controller-1.1.2 (30 Apr 2013)
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.1.4.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.1.4.ebuild
new file mode 100644
index 000000000000..0cd1f926cc80
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/daemon_controller-1.1.4.ebuild,v 1.1 2013/07/14 06:57:01 graaff Exp $
+
+EAPI=5
+
+# jruby → fails tests, looks like Unix sockets are bad on JRuby
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust manner."
+HOMEPAGE="http://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}