summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-05 20:41:11 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-05 20:41:11 +0000
commite7aced139ccc66461556a5f161080033ab3efc36 (patch)
tree2269d14541f017350bd0196407ec3b0faf8026b4 /dev-ruby/commander
parentLinux patch 3.17.0 (diff)
downloadgentoo-2-e7aced139ccc66461556a5f161080033ab3efc36.tar.gz
gentoo-2-e7aced139ccc66461556a5f161080033ab3efc36.tar.bz2
gentoo-2-e7aced139ccc66461556a5f161080033ab3efc36.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/commander')
-rw-r--r--dev-ruby/commander/ChangeLog7
-rw-r--r--dev-ruby/commander/commander-4.2.1.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-ruby/commander/ChangeLog b/dev-ruby/commander/ChangeLog
index c9956828722a..2625ca9fe46b 100644
--- a/dev-ruby/commander/ChangeLog
+++ b/dev-ruby/commander/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/commander
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/commander/ChangeLog,v 1.6 2014/05/02 15:06:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/commander/ChangeLog,v 1.7 2014/10/05 20:41:11 mrueg Exp $
+
+*commander-4.2.1 (05 Oct 2014)
+
+ 05 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +commander-4.2.1.ebuild:
+ Version bump.
*commander-4.2.0 (02 May 2014)
diff --git a/dev-ruby/commander/commander-4.2.1.ebuild b/dev-ruby/commander/commander-4.2.1.ebuild
new file mode 100644
index 000000000000..723159048114
--- /dev/null
+++ b/dev-ruby/commander/commander-4.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/commander/commander-4.2.1.ebuild,v 1.1 2014/10/05 20:41:11 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The complete solution for Ruby command-line executables"
+HOMEPAGE="http://visionmedia.github.com/commander/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/highline-1.6.11"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/end/ s:^:#:" spec/spec_helper.rb || die
+}