summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-18 14:53:30 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-18 14:53:30 +0000
commitf57a4f5c9279036c26b0463aa9a6736de2d5faec (patch)
treed6cfa41e73062087f4e817d66867da3f5d3c6c1a /dev-ruby/coderay
parentVersion bump with bug fixes. (diff)
downloadgentoo-2-f57a4f5c9279036c26b0463aa9a6736de2d5faec.tar.gz
gentoo-2-f57a4f5c9279036c26b0463aa9a6736de2d5faec.tar.bz2
gentoo-2-f57a4f5c9279036c26b0463aa9a6736de2d5faec.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/ChangeLog7
-rw-r--r--dev-ruby/coderay/coderay-0.9.4.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index 1674f9deac95..12b511b0c933 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/coderay
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.20 2010/08/29 11:14:48 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.21 2010/09/18 14:53:29 graaff Exp $
+
+*coderay-0.9.4 (18 Sep 2010)
+
+ 18 Sep 2010; Hans de Graaff <graaff@gentoo.org> +coderay-0.9.4.ebuild:
+ Version bump.
29 Aug 2010; Hans de Graaff <graaff@gentoo.org> coderay-0.9.3.ebuild:
Fix dependencies to test against a compatible version of redcloth, fixes
diff --git a/dev-ruby/coderay/coderay-0.9.4.ebuild b/dev-ruby/coderay/coderay-0.9.4.ebuild
new file mode 100644
index 000000000000..8128c4335683
--- /dev/null
+++ b/dev-ruby/coderay/coderay-0.9.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-0.9.4.ebuild,v 1.1 2010/09/18 14:53:30 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="lib/README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 test" ">=dev-ruby/redcloth-4.2.2"
+USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 test" ">=dev-ruby/redcloth-4.2.2"
+USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 test" ">=dev-ruby/redcloth-4.2.2"