summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-24 14:48:48 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-24 14:48:48 +0000
commitb094d97ed2768589d4ecf419a52d61df39a991b7 (patch)
tree74cb83bbaf9ff9fc1ba4813951c370179832185e /dev-ruby/chunky_png/chunky_png-1.3.3.ebuild
parentKeyword ~ppc ~ppc64, bug #525562 (diff)
downloadgentoo-2-b094d97ed2768589d4ecf419a52d61df39a991b7.tar.gz
gentoo-2-b094d97ed2768589d4ecf419a52d61df39a991b7.tar.bz2
gentoo-2-b094d97ed2768589d4ecf419a52d61df39a991b7.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/chunky_png/chunky_png-1.3.3.ebuild')
-rw-r--r--dev-ruby/chunky_png/chunky_png-1.3.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/chunky_png/chunky_png-1.3.3.ebuild b/dev-ruby/chunky_png/chunky_png-1.3.3.ebuild
new file mode 100644
index 000000000000..c5c8d83060c8
--- /dev/null
+++ b/dev-ruby/chunky_png/chunky_png-1.3.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/chunky_png/chunky_png-1.3.3.ebuild,v 1.1 2014/10/24 14:48:48 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+
+RUBY_FAKEGEM_EXTRADOC="BENCHMARKING.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="chunky_png.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby library that can read and write PNG images"
+HOMEPAGE="http://wiki.github.com/wvanbergen/chunky_png"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/[bB]undler/s:^:#:' {spec,benchmarks}/*.rb || die
+ rm Gemfile* || die
+
+ # Avoid git dependency
+ sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}