summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-19 18:09:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-19 18:09:22 +0000
commit79de7f22ec472a7722f21af4e570804c5133ff09 (patch)
treee4ba7a66dffd7c28b7947d0cd845615f7eb3799a /dev-ruby/async_sinatra
parentCommit the manifest once more. (diff)
downloadgentoo-2-79de7f22ec472a7722f21af4e570804c5133ff09.tar.gz
gentoo-2-79de7f22ec472a7722f21af4e570804c5133ff09.tar.bz2
gentoo-2-79de7f22ec472a7722f21af4e570804c5133ff09.zip
Initial import of async_sinatra gem.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/async_sinatra')
-rw-r--r--dev-ruby/async_sinatra/ChangeLog10
-rw-r--r--dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild38
-rw-r--r--dev-ruby/async_sinatra/metadata.xml5
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/async_sinatra/ChangeLog b/dev-ruby/async_sinatra/ChangeLog
new file mode 100644
index 000000000000..7e733eb961dd
--- /dev/null
+++ b/dev-ruby/async_sinatra/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/async_sinatra
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/ChangeLog,v 1.1 2010/04/19 18:09:22 flameeyes Exp $
+
+*async_sinatra-0.1.5 (19 Apr 2010)
+
+ 19 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +async_sinatra-0.1.5.ebuild, +metadata.xml:
+ Initial import of async_sinatra gem.
+
diff --git a/dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild b/dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild
new file mode 100644
index 000000000000..ca3f4aed783e
--- /dev/null
+++ b/dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/async_sinatra/async_sinatra-0.1.5.ebuild,v 1.1 2010/04/19 18:09:22 flameeyes Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# there are no tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+# the documentation-building requires the gemspec file that is not
+# packaged, this is very unfortunate for us, but the doc does not
+# really tell us much so we're not going out of our way to get this
+# from GIT.
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Asynchronous response API for Sinatra and Thin"
+HOMEPAGE="http://rubyeventmachine.com"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/sinatra-0.9.1
+ >=www-servers/thin-1.2.0'
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/async_sinatra/metadata.xml b/dev-ruby/async_sinatra/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/async_sinatra/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>