summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-17 06:33:48 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-17 06:33:48 +0000
commitac2ba8490886edaa19a7d11d118c370a760ca16b (patch)
treede468227831f598a723b25defc6834901326b43c /dev-ruby/activesupport
parentDev channel bump. Remove old. (diff)
downloadgentoo-2-ac2ba8490886edaa19a7d11d118c370a760ca16b.tar.gz
gentoo-2-ac2ba8490886edaa19a7d11d118c370a760ca16b.tar.bz2
gentoo-2-ac2ba8490886edaa19a7d11d118c370a760ca16b.zip
Version bump for security bug 488298.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.15.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 3ccf44288cf3..15e378c65db9 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.234 2013/10/13 22:05:36 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.235 2013/10/17 06:33:48 graaff Exp $
+
+*activesupport-3.2.15 (17 Oct 2013)
+
+ 17 Oct 2013; Hans de Graaff <graaff@gentoo.org> +activesupport-3.2.15.ebuild:
+ Version bump for security bug 488298.
13 Oct 2013; Markus Meier <maekke@gentoo.org> activesupport-4.0.0.ebuild:
add ~arm, bug #487206
diff --git a/dev-ruby/activesupport/activesupport-3.2.15.ebuild b/dev-ruby/activesupport/activesupport-3.2.15.ebuild
new file mode 100644
index 000000000000..9fc30f16637c
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.2.15.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.15.ebuild,v 1.1 2013/10/17 06:33:48 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.0
+ >=dev-ruby/i18n-0.6.4:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/memcache-client-1.5.8
+ dev-ruby/nokogiri
+ >=dev-ruby/builder-3.0.3:3
+ >=dev-ruby/tzinfo-0.3.29
+ )"
+
+# libxml is not strictly needed, there are tests using this code. jruby
+# uses a different xml implementation.
+USE_RUBY=${USE_RUBY/jruby/} ruby_add_bdepend "test? ( >=dev-ruby/libxml-2.0.0 )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby18)
+ # Skip failing ruby18 tests related to JSON serialization
+ rm test/message_encryptor_test.rb test/message_verifier_test.rb || die
+ ;;
+ *jruby)
+ # Ignore failing tests on jruby in the interest of a security update
+ sed -i -e '/test_not_allowed_to_expand_parameter_entities_to_files/,/^ end/ s:^:#:' \
+ -e '/test_exception_thrown_on_expansion_attack/,/^ end/ s:^:#:' \
+ test/xml_mini/jdom_engine_test.rb || die
+ sed -i \
+ -e '/test_exception_thrown_on_expansion_attack/,/^ end/ s:^:#:' \
+ test/xml_mini/nokogiri_engine_test.rb || die
+ ;;
+ esac
+}