summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-12-27 13:07:18 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2011-12-27 13:07:18 +0000
commite0eb702867fc4dfa888c33ae148cbde4a41292d2 (patch)
tree8d7b5a53b904d5c0d9f300751c580d853aaa8658 /dev-python
parentAdd ruby19. Fix test suite to always use the ruby interpreter tested. (diff)
downloadgentoo-2-e0eb702867fc4dfa888c33ae148cbde4a41292d2.tar.gz
gentoo-2-e0eb702867fc4dfa888c33ae148cbde4a41292d2.tar.bz2
gentoo-2-e0eb702867fc4dfa888c33ae148cbde4a41292d2.zip
dev-python/diff-match-patch: Initial ebuild.
(Portage version: 2.1.10.43/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/diff-match-patch/ChangeLog10
-rw-r--r--dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild46
-rw-r--r--dev-python/diff-match-patch/metadata.xml29
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/diff-match-patch/ChangeLog b/dev-python/diff-match-patch/ChangeLog
new file mode 100644
index 000000000000..40ce9e97595e
--- /dev/null
+++ b/dev-python/diff-match-patch/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/diff-match-patch
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/diff-match-patch/ChangeLog,v 1.1 2011/12/27 13:07:18 aidecoe Exp $
+
+*diff-match-patch-20110725.1 (27 Dec 2011)
+
+ 27 Dec 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +diff-match-patch-20110725.1.ebuild, +metadata.xml:
+ Initial ebuild.
+
diff --git a/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild b/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild
new file mode 100644
index 000000000000..dd0c06cb0c9f
--- /dev/null
+++ b/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/diff-match-patch/diff-match-patch-20110725.1.ebuild,v 1.1 2011/12/27 13:07:18 aidecoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Diff, match and patch algorithms for plain text"
+HOMEPAGE="http://code.google.com/p/google-diff-match-patch/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+TEST_SCRIPT="${PN//-/_}/${PN//-/_}_test.py"
+
+src_prepare() {
+ python_convert_shebangs -r 2 python2/*
+}
+
+src_test() {
+ testing() {
+ local pylib="build-${PYTHON_ABI}/lib"
+ PYTHONPATH="${pylib}" "$(PYTHON)" "${pylib}/${TEST_SCRIPT}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm "${D}/$(python_get_sitedir)/${TEST_SCRIPT}" || die
+ }
+
+ python_execute_function -q delete_tests
+}
diff --git a/dev-python/diff-match-patch/metadata.xml b/dev-python/diff-match-patch/metadata.xml
new file mode 100644
index 000000000000..d187606299cb
--- /dev/null
+++ b/dev-python/diff-match-patch/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Diff Match and Patch libraries offer robust algorithms to perform
+ the operations required for synchronizing plain text.
+
+ Diff: Compare two blocks of plain text and efficiently return a list of
+ differences.
+
+ Match: Given a search string, find its best fuzzy match in a block of
+ plain text. Weighted for both accuracy and location.
+
+ Patch: Apply a list of patches onto plain text. Use best-effort to apply
+ patch even when the underlying text doesn't match.
+
+ Diff Match and Patch libraries are currently available in Java,
+ JavaScript, C++, C#, Objective C, Lua and Python, although this package
+ contains only Python implementation. Regardless of language, each
+ library features the same API and the same functionality. All versions
+ also have comprehensive test harnesses.
+ </longdescription>
+</pkgmetadata>
+