summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-12-11 20:25:33 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-12-11 20:25:33 +0000
commitd5055ac5dd9a9e9e9c5a71ea940941f4ce320402 (patch)
tree2bb6d6cf575f07e9af88da461c863c07244fef2f /dev-python
parentChanged from insinto/doins to newinitd. (Manifest recommit) (diff)
downloadgentoo-2-d5055ac5dd9a9e9e9c5a71ea940941f4ce320402.tar.gz
gentoo-2-d5055ac5dd9a9e9e9c5a71ea940941f4ce320402.tar.bz2
gentoo-2-d5055ac5dd9a9e9e9c5a71ea940941f4ce320402.zip
Put headers in a better place. Closes #74019
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/Manifest15
-rw-r--r--dev-python/wxpython/wxpython-2.5.3.1.ebuild11
3 files changed, 18 insertions, 14 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 336fd9547dbf..ae15b5d22222 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.13 2004/11/13 23:05:05 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.14 2004/12/11 20:25:33 pythonhead Exp $
+
+ 11 Dec 2004; Rob Cakebread <pythonhead@gentoo.org>
+ wxpython-2.5.3.1.ebuild:
+ Put headers in a better place. Closes #74019
13 Nov 2004; Rob Cakebread <pythonhead@gentoo.org>
wxpython-2.5.3.1.ebuild:
diff --git a/dev-python/wxpython/Manifest b/dev-python/wxpython/Manifest
index ab6aa2f43b19..e1e894ef3b50 100644
--- a/dev-python/wxpython/Manifest
+++ b/dev-python/wxpython/Manifest
@@ -1,20 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 3b06f1e87549af51d78bb7bfa33728b5 metadata.xml 182
MD5 03005fb45223144f46f174425229dd97 wxpython-2.4.2.4.ebuild 2426
-MD5 91069f4d015cd8013ba0cc7eb6c6c3e0 wxpython-2.5.3.1.ebuild 3098
-MD5 53ccea69143f2740f2052260ddb6b20a ChangeLog 8515
+MD5 25265dcc875d1d9624fadcc71bfdb652 wxpython-2.5.3.1.ebuild 3395
+MD5 7b2ab55f3b30b2840d4218e6ea7c451f ChangeLog 8643
MD5 f959ab3869a044126ad9b66353cc68b1 wxpython-2.4.2.4-r1.ebuild 3565
+MD5 2867bba4424918d6b319f13ba12f3844 .wxpython-2.5.3.1.ebuild.swp 12288
MD5 d1efabd4c6bcd5edd9e61ca070e20ff0 files/digest-wxpython-2.4.2.4-r1 73
MD5 83d82d05e77457e559cf175012f538e7 files/digest-wxpython-2.5.3.1 74
MD5 49c68d8febf658844a392bd0108fdf10 files/wxversion.py 14404
MD5 d1efabd4c6bcd5edd9e61ca070e20ff0 files/digest-wxpython-2.4.2.4 73
MD5 960f9cf74312ac4829b96c63739fcfe9 files/wxpy-config.py 3275
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBlpMrz2gxt1z4IGYRAuz6AKCv4MH3I3twD8wP+N9SpNY6KTBuFACgzK9U
-91hcYgyejbY75RaUtBGVgjQ=
-=CyWj
------END PGP SIGNATURE-----
diff --git a/dev-python/wxpython/wxpython-2.5.3.1.ebuild b/dev-python/wxpython/wxpython-2.5.3.1.ebuild
index 1cda9d8807ba..1e1f4efb3eea 100644
--- a/dev-python/wxpython/wxpython-2.5.3.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.5.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.5.3.1.ebuild,v 1.3 2004/11/13 23:05:05 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.5.3.1.ebuild,v 1.4 2004/12/11 20:25:33 pythonhead Exp $
inherit python wxwidgets
@@ -82,6 +82,15 @@ src_install() {
local site_pkgs=/usr/lib/python${PYVER}/site-packages
dodir ${site_pkgs}
+ if ! use gtk2; then
+ need-wxwidgets gtk || die "Emerge wxGTK with -no_wxgtk1 in USE"
+ elif use unicode; then
+ need-wxwidgets unicode || die "Emerge wxGTK with unicode in USE"
+ else
+ need-wxwidgets gtk2 || die "Emerge wxGTK with gtk2 in USE"
+ fi
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
|| mypyconf="${mypyconf} BUILD_GLCANVAS=0"