summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-10-22 15:12:11 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-10-22 15:12:11 +0000
commitb5f66a88100a25f65e3db4ddf4e4164fddfc6045 (patch)
treee658cd46b680df436c286792e0ae8832c0d9ed13 /dev-python
parentPython 2.5 compatibility. (diff)
downloadgentoo-2-b5f66a88100a25f65e3db4ddf4e4164fddfc6045.tar.gz
gentoo-2-b5f66a88100a25f65e3db4ddf4e4164fddfc6045.tar.bz2
gentoo-2-b5f66a88100a25f65e3db4ddf4e4164fddfc6045.zip
Python 2.5 compatibility.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog8
-rw-r--r--dev-python/PyQt/PyQt-3.14.1-r2.ebuild57
-rw-r--r--dev-python/PyQt/files/PyQt-3.14.1-python-2.5-compat.diff87
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.14.1-r12
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.14.1-r23
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.162
6 files changed, 158 insertions, 1 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index 0a23103f6f10..ec684a3dc752 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.71 2006/04/06 14:36:32 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.72 2006/10/22 15:12:11 carlo Exp $
+
+*PyQt-3.14.1-r2 (22 Oct 2006)
+
+ 22 Oct 2006; Carsten Lohrke <carlo@gentoo.org>
+ +files/PyQt-3.14.1-python-2.5-compat.diff, +PyQt-3.14.1-r2.ebuild:
+ Python 2.5 compatibility.
*PyQt-3.16 (06 Apr 2006)
diff --git a/dev-python/PyQt/PyQt-3.14.1-r2.ebuild b/dev-python/PyQt/PyQt-3.14.1-r2.ebuild
new file mode 100644
index 000000000000..82821d64b867
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.14.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.14.1-r2.ebuild,v 1.1 2006/10/22 15:12:11 carlo Exp $
+
+inherit distutils eutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="x11-libs/qt
+ ~dev-python/sip-4.2.1
+ dev-python/qscintilla"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s: check_license():# check_license():" ${S}/configure.py
+ cd ${S}
+ epatch "${FILESDIR}/PyQt-3.14.1-examples.diff"
+ epatch "${FILESDIR}/PyQt-3.14.1-python-2.5-compat.diff"
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages \
+ -b ${ROOT}/usr/bin \
+ -v ${ROOT}/usr/share/sip \
+ -n ${ROOT}/usr/include \
+ -o ${ROOT}/usr/$(get_libdir)"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+ use doc && dohtml doc/PyQt.html
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* ${D}/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt/files/PyQt-3.14.1-python-2.5-compat.diff b/dev-python/PyQt/files/PyQt-3.14.1-python-2.5-compat.diff
new file mode 100644
index 000000000000..60b99cbee1d3
--- /dev/null
+++ b/dev-python/PyQt/files/PyQt-3.14.1-python-2.5-compat.diff
@@ -0,0 +1,87 @@
+--- sip/qt/qdir.sip.orig 2006-10-12 17:28:37.000000000 +0200
++++ sip/qt/qdir.sip 2006-10-12 17:29:43.000000000 +0200
+@@ -238,7 +238,7 @@
+
+ QString operator[](int) const;
+ %MethodCode
+- int len;
++ ssize_t len;
+
+ Py_BEGIN_ALLOW_THREADS
+ len = sipCpp -> count();
+@@ -256,7 +256,7 @@
+
+ QStringList operator[](SIP_PYSLICE) const;
+ %MethodCode
+- int len, start, stop, step, slicelength;
++ ssize_t len, start, stop, step, slicelength;
+
+ Py_BEGIN_ALLOW_THREADS
+ len = sipCpp -> count();
+--- sip/qt/qstring.sip 2005/09/29 14:33:08 465369
++++ sip/qt/qstring.sip 2006/10/11 22:54:45 594670
+@@ -746,7 +746,7 @@
+
+ QString operator[](SIP_PYSLICE) const;
+ %MethodCode
+- int len, start, stop, step, slicelength;
++ ssize_t len, start, stop, step, slicelength;
+
+ len = sipCpp -> length();
+
+--- sip/qt/qstringlist.sip 2005/09/29 14:33:08 465369
++++ sip/qt/qstringlist.sip 2006/10/11 22:54:45 594670
+@@ -99,7 +99,7 @@
+
+ void __setitem__(int,const QString &);
+ %MethodCode
+- int len;
++ ssize_t len;
+
+ len = sipCpp -> count();
+
+@@ -111,7 +111,7 @@
+
+ void __setitem__(SIP_PYSLICE,const QStringList &);
+ %MethodCode
+- int len, start, stop, step, slicelength;
++ ssize_t len, start, stop, step, slicelength;
+
+ len = sipCpp -> count();
+
+@@ -142,7 +142,7 @@
+
+ void __delitem__(int);
+ %MethodCode
+- int len;
++ ssize_t len;
+
+ len = sipCpp -> count();
+
+@@ -154,7 +154,7 @@
+
+ void __delitem__(SIP_PYSLICE);
+ %MethodCode
+- int len, start, stop, step, slicelength;
++ ssize_t len, start, stop, step, slicelength;
+
+ len = sipCpp -> count();
+
+@@ -170,7 +170,7 @@
+
+ QString operator[](int);
+ %MethodCode
+- int len;
++ ssize_t len;
+
+ len = sipCpp -> count();
+
+@@ -182,7 +182,7 @@
+
+ QStringList operator[](SIP_PYSLICE);
+ %MethodCode
+- int len, start, stop, step, slicelength;
++ ssize_t len, start, stop, step, slicelength;
+
+ len = sipCpp -> count();
+
diff --git a/dev-python/PyQt/files/digest-PyQt-3.14.1-r1 b/dev-python/PyQt/files/digest-PyQt-3.14.1-r1
index a7791cbd39b4..b03a0406f6d8 100644
--- a/dev-python/PyQt/files/digest-PyQt-3.14.1-r1
+++ b/dev-python/PyQt/files/digest-PyQt-3.14.1-r1
@@ -1 +1,3 @@
MD5 bf6d939ec77e48a2db7561e7bac61d19 PyQt-x11-gpl-3.14.1.tar.gz 782274
+RMD160 d8caef8513bc715f2f0e6107daa5d6d2ba883ddb PyQt-x11-gpl-3.14.1.tar.gz 782274
+SHA256 0dce9b536a04d89934334c5ace498cce31fc8a435ed4ef6ac2eb16256573f555 PyQt-x11-gpl-3.14.1.tar.gz 782274
diff --git a/dev-python/PyQt/files/digest-PyQt-3.14.1-r2 b/dev-python/PyQt/files/digest-PyQt-3.14.1-r2
new file mode 100644
index 000000000000..b03a0406f6d8
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.14.1-r2
@@ -0,0 +1,3 @@
+MD5 bf6d939ec77e48a2db7561e7bac61d19 PyQt-x11-gpl-3.14.1.tar.gz 782274
+RMD160 d8caef8513bc715f2f0e6107daa5d6d2ba883ddb PyQt-x11-gpl-3.14.1.tar.gz 782274
+SHA256 0dce9b536a04d89934334c5ace498cce31fc8a435ed4ef6ac2eb16256573f555 PyQt-x11-gpl-3.14.1.tar.gz 782274
diff --git a/dev-python/PyQt/files/digest-PyQt-3.16 b/dev-python/PyQt/files/digest-PyQt-3.16
index eec43371e307..30940eeff9fe 100644
--- a/dev-python/PyQt/files/digest-PyQt-3.16
+++ b/dev-python/PyQt/files/digest-PyQt-3.16
@@ -1 +1,3 @@
MD5 5f7a32a15bf8afe17c0d0a0cc46de690 PyQt-x11-gpl-3.16.tar.gz 800618
+RMD160 463c1e1a43aece2abaea1356aa04c62efb3ff894 PyQt-x11-gpl-3.16.tar.gz 800618
+SHA256 e3f5b10ef5e7dd4c79e97c2ee7171af857ad7ea1d36919c09d7bd504b8676d26 PyQt-x11-gpl-3.16.tar.gz 800618