summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-02 17:41:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-02 17:41:02 +0000
commita44763400be444f884d018d076bfdb996cc9406f (patch)
tree49a7a25e826510e8ba093292467f613609682fc8 /dev-python
parentKeyword amd64-linux and x86-linux (diff)
downloadgentoo-2-a44763400be444f884d018d076bfdb996cc9406f.tar.gz
gentoo-2-a44763400be444f884d018d076bfdb996cc9406f.tar.bz2
gentoo-2-a44763400be444f884d018d076bfdb996cc9406f.zip
Keyword amd64-linux and x86-linux
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pywcs/ChangeLog7
-rw-r--r--dev-python/pywcs/files/pywcs-1.9-wcslib.patch121
-rw-r--r--dev-python/pywcs/pywcs-1.11.ebuild4
-rw-r--r--dev-python/pywcs/pywcs-1.9.ebuild48
4 files changed, 7 insertions, 173 deletions
diff --git a/dev-python/pywcs/ChangeLog b/dev-python/pywcs/ChangeLog
index 5d43b4e55901..e7dc69f2ea9f 100644
--- a/dev-python/pywcs/ChangeLog
+++ b/dev-python/pywcs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pywcs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywcs/ChangeLog,v 1.5 2012/05/04 15:12:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywcs/ChangeLog,v 1.6 2012/08/02 17:41:02 bicatali Exp $
+
+ 02 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/pywcs-1.9-wcslib.patch, -pywcs-1.9.ebuild, pywcs-1.11.ebuild:
+ Keyword amd64-linux and x86-linux
04 May 2012; Patrick Lauer <patrick@gentoo.org> pywcs-1.11.ebuild,
pywcs-1.9.ebuild:
@@ -60,4 +64,3 @@
26 Jun 2009; Sébastien Fabbro <bicatali@gentoo.org> +pywcs-1.4.2.ebuild,
+metadata.xml:
Initial import
-
diff --git a/dev-python/pywcs/files/pywcs-1.9-wcslib.patch b/dev-python/pywcs/files/pywcs-1.9-wcslib.patch
deleted file mode 100644
index 1ce9cf59a50a..000000000000
--- a/dev-python/pywcs/files/pywcs-1.9-wcslib.patch
+++ /dev/null
@@ -1,121 +0,0 @@
---- defsetup.py.orig 2010-07-21 16:01:17.000000000 +0200
-+++ defsetup.py 2010-08-17 17:20:16.761079432 +0200
-@@ -38,71 +38,26 @@
-
- ######################################################################
- # WCSLIB
--WCSVERSION = "4.4.4"
--WCSLIB = "wcslib-%s" % WCSVERSION # Path to wcslib
--WCSLIBC = join(WCSLIB, "C") # Path to wcslib source files
--WCSFILES = [ # List of wcslib files to compile
-- 'flexed/wcsbth.c',
-- 'flexed/wcspih.c',
-- 'flexed/wcsulex.c',
-- 'flexed/wcsutrn.c',
-- 'cel.c',
-- 'lin.c',
-- 'log.c',
-- 'prj.c',
-- 'spc.c',
-- 'sph.c',
-- 'spx.c',
-- 'tab.c',
-- 'wcs.c',
-- 'wcsfix.c',
-- 'wcshdr.c',
-- 'wcsunits.c',
-- 'wcsutil.c']
--WCSFILES = [join(WCSLIBC, x) for x in WCSFILES]
-+from subprocess import Popen, PIPE
-+from re import match
-
--######################################################################
--# WCSLIB CONFIGURATION
--
--# The only configuration parameter needed at compile-time is how to
--# specify a 64-bit signed integer. Python's ctypes module can get us
--# that information, but it is only available in Python 2.5 or later.
--# If we can't be absolutely certain, we default to "long long int",
--# which is correct on most platforms (x86, x86_64). If we find
--# platforms where this heuristic doesn't work, we may need to hardcode
--# for them.
--def determine_64_bit_int():
-- try:
-- try:
-- import ctypes
-- except ImportError:
-- raise ValueError()
--
-- if ctypes.sizeof(ctypes.c_longlong) == 8:
-- return "long long int"
-- elif ctypes.sizeof(ctypes.c_long) == 8:
-- return "long int"
-- elif ctypes.sizeof(ctypes.c_int) == 8:
-- return "int"
-- else:
-- raise ValueError()
-+def pkgconfig(*packages, **kw):
-+ flag_map = {'-I': 'include_dirs', '-L': 'library_dirs', '-l': 'libraries'}
-+ arg = "--libs --cflags --modversion %s" % ' '.join(packages)
-+ for token in Popen(["pkg-config "+ arg],stdout=PIPE, shell=True).communicate()[0].split():
-+ if(match("[0-9]",token)):
-+ kw.setdefault("version",[]).append(token)
-+ else:
-+ kw.setdefault(flag_map.get(token[:2]), []).append(token[2:])
-+ return kw
-
-- except ValueError:
-- return "long long int"
-+WCSLIB = pkgconfig('wcslib')
-+WCSVERSION = WCSLIB['version'][0]
-
- if os.path.exists("pywcs"):
- srcroot = 'pywcs'
- else:
- srcroot = '.'
--fd = open(join(srcroot, 'src', 'wcsconfig.h'), "w")
--fd.write("""
--/* WCSLIB library version number. */
--#define WCSLIB_VERSION %s
--
--/* 64-bit integer data type. */
--#define WCSLIB_INT64 %s
--""" % (WCSVERSION, determine_64_bit_int()))
--fd.close()
-
- ######################################################################
- # GENERATE DOCSTRINGS IN C
-@@ -191,7 +146,8 @@
-
- ######################################################################
- # DISTUTILS SETUP
--libraries = []
-+libraries = WCSLIB['libraries']
-+include_dirs = [numpy_include, join(srcroot, "src")] + WCSLIB['include_dirs']
- define_macros = [('ECHO', None),
- ('WCSTRIG_MACRO', None),
- ('PYWCS_BUILD', None),
-@@ -234,13 +190,8 @@
-
- PYWCS_EXTENSIONS = [
- Extension('pywcs._pywcs',
-- WCSFILES + PYWCS_SOURCES,
-- include_dirs =
-- [numpy_include,
-- join(srcroot, WCSLIBC),
-- WCSLIBC,
-- join(srcroot, "src")
-- ],
-+ PYWCS_SOURCES,
-+ include_dirs=include_dirs,
- define_macros=define_macros,
- undef_macros=undef_macros,
- extra_compile_args=extra_compile_args,
-@@ -260,7 +211,6 @@
- 'ext_modules' : PYWCS_EXTENSIONS,
- 'data_files' : [
- ( 'pywcs/include', ['src/*.h']),
-- ( 'pywcs/include/wcslib', [ WCSLIBC + '/*.h'] ),
- ],
- 'package_dir' : {pkg[0]: 'lib', pkg[1]: 'test'},
- }
diff --git a/dev-python/pywcs/pywcs-1.11.ebuild b/dev-python/pywcs/pywcs-1.11.ebuild
index b17bbc17668d..df7e698ef786 100644
--- a/dev-python/pywcs/pywcs-1.11.ebuild
+++ b/dev-python/pywcs/pywcs-1.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywcs/pywcs-1.11.ebuild,v 1.3 2012/05/04 15:12:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywcs/pywcs-1.11.ebuild,v 1.4 2012/08/02 17:41:02 bicatali Exp $
EAPI=4
@@ -18,7 +18,7 @@ SRC_URI="http://stsdas.stsci.edu/astrolib/${MYP}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
CDEPEND=">=sci-astronomy/wcslib-${WCS_V}"
diff --git a/dev-python/pywcs/pywcs-1.9.ebuild b/dev-python/pywcs/pywcs-1.9.ebuild
deleted file mode 100644
index 52d36689455b..000000000000
--- a/dev-python/pywcs/pywcs-1.9.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywcs/pywcs-1.9.ebuild,v 1.3 2012/05/04 15:12:15 patrick Exp $
-
-EAPI=3
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.7-pypy-* *-jython"
-
-inherit distutils eutils
-
-WCS_V=4.4.4
-MYP="${P}-${WCS_V}"
-
-DESCRIPTION="Python routines for handling the FITS World Coordinate System"
-HOMEPAGE="https://trac6.assembla.com/astrolib/wiki http://www.scipy.org/AstroLib"
-SRC_URI="http://stsdas.stsci.edu/astrolib/${MYP}.tar.gz"
-
-IUSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-LICENSE="BSD"
-
-COMMON_DEPEND=">=sci-astronomy/wcslib-${WCS_V}"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
-RDEPEND="${COMMON_DEPEND}
- dev-python/pyfits"
-
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MYP}"
-
-src_prepare(){
- epatch "${FILESDIR}"/${P}-wcslib.patch
-}
-
-src_test() {
- # FIX: does not work, needs fits files
- testing() {
- PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" \
- "$(PYTHON)" test/test.py
- }
- python_execute_function testing
-}
-
-#FIX: compiles twice (once during build, another time during install)
-# seems to be in the defsetup.py hack script