summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 01:35:31 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 01:35:31 +0000
commita1899b6d66bff43a4cf282643b1eba29d030e2d2 (patch)
tree70194de38393bbffc5ad1524ba5e2cb68ab0a8a4 /dev-python
parentDelete older ebuild. (diff)
downloadgentoo-2-a1899b6d66bff43a4cf282643b1eba29d030e2d2.tar.gz
gentoo-2-a1899b6d66bff43a4cf282643b1eba29d030e2d2.tar.bz2
gentoo-2-a1899b6d66bff43a4cf282643b1eba29d030e2d2.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dpkt/ChangeLog10
-rw-r--r--dev-python/dpkt/dpkt-1.7.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/dpkt/ChangeLog b/dev-python/dpkt/ChangeLog
index 672498d3cb9a..3e457c9b6a45 100644
--- a/dev-python/dpkt/ChangeLog
+++ b/dev-python/dpkt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dpkt
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/ChangeLog,v 1.3 2009/05/16 21:22:18 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/ChangeLog,v 1.4 2010/07/01 01:35:31 arfrever Exp $
+
+*dpkt-1.7 (01 Jul 2010)
+
+ 01 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -dpkt-1.6.ebuild, -files/dpkt-1.6-python-2.6.patch, +dpkt-1.7.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
16 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
dpkt-1.6.ebuild, +files/dpkt-1.6-python-2.6.patch:
diff --git a/dev-python/dpkt/dpkt-1.7.ebuild b/dev-python/dpkt/dpkt-1.7.ebuild
new file mode 100644
index 000000000000..e4f9ad8dc8d2
--- /dev/null
+++ b/dev-python/dpkt/dpkt-1.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dpkt/dpkt-1.7.ebuild,v 1.1 2010/07/01 01:35:31 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Fast, simple packet creation / parsing, with definitions for the basic TCP/IP protocols."
+HOMEPAGE="http://code.google.com/p/dpkt/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="AUTHORS CHANGES HACKING"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/test-perf2.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}