summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-26 05:54:25 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-26 05:54:25 +0000
commit92c08e42310e8a4c21b1a3c0df542daf0972cab0 (patch)
treef25a41bee0b64f415a06a3f21224ab14bc38ef7e /dev-python
parentMaintainer -> app-doc. Shorten description. (diff)
downloadgentoo-2-92c08e42310e8a4c21b1a3c0df542daf0972cab0.tar.gz
gentoo-2-92c08e42310e8a4c21b1a3c0df542daf0972cab0.tar.bz2
gentoo-2-92c08e42310e8a4c21b1a3c0df542daf0972cab0.zip
dev-python/mpmath: Add missing dep on pytest for tests, remove src_test and use eclass default, restrict pypy
(Portage version: 2.2.0_alpha113/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mpmath/ChangeLog6
-rw-r--r--dev-python/mpmath/mpmath-0.17.ebuild19
2 files changed, 12 insertions, 13 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
index ee25ec5f8368..261fe8c587c8 100644
--- a/dev-python/mpmath/ChangeLog
+++ b/dev-python/mpmath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mpmath
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.21 2012/06/26 03:13:34 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.22 2012/06/26 05:54:25 jlec Exp $
+
+ 26 Jun 2012; Justin Lecher <jlec@gentoo.org> mpmath-0.17.ebuild:
+ Add missing dep on pytest for tests, remove src_test and use eclass default,
+ restrict pypy
26 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org>
+files/mpmath-0.17-python-3.2.patch, mpmath-0.17.ebuild:
diff --git a/dev-python/mpmath/mpmath-0.17.ebuild b/dev-python/mpmath/mpmath-0.17.ebuild
index 8ded3d403dd0..f623bfbff036 100644
--- a/dev-python/mpmath/mpmath-0.17.ebuild
+++ b/dev-python/mpmath/mpmath-0.17.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.17.ebuild,v 1.4 2012/06/26 03:13:34 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.17.ebuild,v 1.5 2012/06/26 05:54:25 jlec Exp $
EAPI=4
PYTHON_DEPEND="*:2.5"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-pypy-*"
DISTUTILS_SRC_TEST="py.test"
inherit distutils eutils
@@ -26,7 +27,8 @@ RDEPEND="
gmp? ( dev-python/gmpy )
matplotlib? ( dev-python/matplotlib )"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest )"
S="${WORKDIR}/${MY_P}"
@@ -36,8 +38,9 @@ src_prepare() {
distutils_src_prepare
# don't install tests
- epatch "${FILESDIR}/${PN}.patch"
- epatch "${FILESDIR}"/${P}-python-3.2.patch
+ epatch \
+ "${FILESDIR}/${PN}.patch" \
+ "${FILESDIR}/${P}-python-3.2.patch"
# this fails with the current version of dev-python/py
rm -f ${PN}/conftest.py
@@ -57,14 +60,6 @@ src_compile() {
fi
}
-src_test() {
- testing() {
- cd "${S}"/mpmath/tests
- PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" runtests.py
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install