summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-17 09:05:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-17 09:05:35 +0000
commit52c6827490f2425e11986276fe7ca38a9afe1cab (patch)
tree07cc7e090a3bff5eb3606736a82885b57211e729 /dev-python
parentRestricting py 2.5 (diff)
downloadgentoo-2-52c6827490f2425e11986276fe7ca38a9afe1cab.tar.gz
gentoo-2-52c6827490f2425e11986276fe7ca38a9afe1cab.tar.bz2
gentoo-2-52c6827490f2425e11986276fe7ca38a9afe1cab.zip
Bump, restricting pythons
(Portage version: 2.2.0_alpha139/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/subvertpy/ChangeLog8
-rw-r--r--dev-python/subvertpy/subvertpy-0.9.0.ebuild39
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-python/subvertpy/ChangeLog b/dev-python/subvertpy/ChangeLog
index 4c1bc6b724a7..b8e40a644ba3 100644
--- a/dev-python/subvertpy/ChangeLog
+++ b/dev-python/subvertpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/subvertpy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.47 2012/09/30 18:05:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/ChangeLog,v 1.48 2012/10/17 09:05:35 patrick Exp $
+
+*subvertpy-0.9.0 (17 Oct 2012)
+
+ 17 Oct 2012; Patrick Lauer <patrick@gentoo.org> +subvertpy-0.9.0.ebuild:
+ Bump, restricting pythons
30 Sep 2012; Raúl Porcel <armin76@gentoo.org> subvertpy-0.8.0.ebuild,
subvertpy-0.8.9.ebuild, subvertpy-0.8.10.ebuild:
@@ -190,4 +195,3 @@
+metadata.xml:
Initial import, ebuild initially from bazaar overlay. Fixes bug #270201,
thank Johan Bergström and Mark Lee.
-
diff --git a/dev-python/subvertpy/subvertpy-0.9.0.ebuild b/dev-python/subvertpy/subvertpy-0.9.0.ebuild
new file mode 100644
index 000000000000..857a4c1a69de
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subvertpy/subvertpy-0.9.0.ebuild,v 1.1 2012/10/17 09:05:35 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.* *-jython 2.7-pypy-1.8"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="http://samba.org/~jelmer/subvertpy/ http://pypi.python.org/pypi/subvertpy"
+SRC_URI="http://samba.org/~jelmer/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-vcs/subversion-1.4"
+DEPEND="${RDEPEND}
+ test? ( || (
+ dev-lang/python:2.7
+ dev-python/unittest2
+ dev-python/testtools
+ ) )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="NEWS AUTHORS"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _ra client repos wc; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/subvertpy/${module}.so" "subvertpy/${module}.so" || die "Symlinking subvertpy/${module}.so failed with $(python_get_implementation) $(python_get_version)"
+ done
+}