summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-22 10:03:39 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-22 10:03:39 +0000
commit51da98578a5e6c90528ea8c001189e69f8e5a221 (patch)
treeb41a819f9e57419dfeb254e934c34a990f28175e /dev-python
parentMarked ~hppa (bug #525246). (diff)
downloadgentoo-2-51da98578a5e6c90528ea8c001189e69f8e5a221.tar.gz
gentoo-2-51da98578a5e6c90528ea8c001189e69f8e5a221.tar.bz2
gentoo-2-51da98578a5e6c90528ea8c001189e69f8e5a221.zip
bump; clean old python impls, update SRC_URI and deps, add IUSE doc and all that goes with doc build, fix issue re fno-strict-aliasing under py2, rm old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gmpy/ChangeLog9
-rw-r--r--dev-python/gmpy/gmpy-1.17.ebuild38
-rw-r--r--dev-python/gmpy/gmpy-2.0.4.ebuild60
3 files changed, 68 insertions, 39 deletions
diff --git a/dev-python/gmpy/ChangeLog b/dev-python/gmpy/ChangeLog
index 3e3d9a4131a0..7d151fed330f 100644
--- a/dev-python/gmpy/ChangeLog
+++ b/dev-python/gmpy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/gmpy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gmpy/ChangeLog,v 1.43 2014/08/27 12:06:13 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gmpy/ChangeLog,v 1.44 2014/10/22 10:03:39 idella4 Exp $
+
+*gmpy-2.0.4 (22 Oct 2014)
+
+ 22 Oct 2014; Ian Delaney <idella4@gentoo.org> +gmpy-2.0.4.ebuild,
+ -gmpy-1.17.ebuild:
+ bump; clean old python impls, update SRC_URI and deps, add IUSE doc and all
+ that goes with doc build, fix issue re fno-strict-aliasing under py2, rm old
27 Aug 2014; Anthony G. Basile <blueness@gentoo.org> gmpy-1.16.ebuild,
gmpy-1.17.ebuild, gmpy-2.0.0.ebuild, gmpy-2.0.3.ebuild:
diff --git a/dev-python/gmpy/gmpy-1.17.ebuild b/dev-python/gmpy/gmpy-1.17.ebuild
deleted file mode 100644
index 2c294b7eb163..000000000000
--- a/dev-python/gmpy/gmpy-1.17.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gmpy/gmpy-1.17.ebuild,v 1.3 2014/08/27 12:06:13 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for GMP library"
-HOMEPAGE="http://www.aleax.it/gmpy.html http://code.google.com/p/gmpy/ http://pypi.python.org/pypi/gmpy"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos"
-IUSE=""
-
-RDEPEND="dev-libs/gmp"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-DOCS=( doc/gmpydoc.txt )
-HTML_DOCS=( doc/index.html )
-
-python_test() {
- if $(python_is_python3); then
- pushd test3 > /dev/null
- else
- pushd test > /dev/null
- fi
- sed \
- -e 's:_test():_test(chat=True):g' \
- -i gmpy_test.py || die
- "${EPYTHON}" gmpy_test.py || return 1
- popd > /dev/null
-}
diff --git a/dev-python/gmpy/gmpy-2.0.4.ebuild b/dev-python/gmpy/gmpy-2.0.4.ebuild
new file mode 100644
index 000000000000..3c9a08b73730
--- /dev/null
+++ b/dev-python/gmpy/gmpy-2.0.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gmpy/gmpy-2.0.4.ebuild,v 1.1 2014/10/22 10:03:39 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for GMP, MPC, MPFR and MPIR libraries"
+HOMEPAGE="http://code.google.com/p/gmpy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc mpir"
+
+RDEPEND="
+ >=dev-libs/mpc-1.0.2
+ >=dev-libs/mpfr-3.1.2
+ !mpir? ( dev-libs/gmp )
+ mpir? ( sci-libs/mpir )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"/${MY_P}
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(usex mpir --mpir --gmp)
+ )
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ cd test || die
+ ${PYTHON} runtests.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}