summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-05-18 16:53:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-05-18 16:53:51 +0000
commit4eb4eb8d2e4edf62470acf35b33a98799a186b8d (patch)
treea0b8d5bbb64286ceb7e77e7eba23d0d61cd4c1c4 /dev-python
parentVersion bump, bug #318771, ebuild contributed by Nicolas Dufresne (diff)
downloadgentoo-2-4eb4eb8d2e4edf62470acf35b33a98799a186b8d.tar.gz
gentoo-2-4eb4eb8d2e4edf62470acf35b33a98799a186b8d.tar.bz2
gentoo-2-4eb4eb8d2e4edf62470acf35b33a98799a186b8d.zip
Removed .la file, now does not build static library, which is probably useless. Removed old version
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pythonmagick/ChangeLog9
-rw-r--r--dev-python/pythonmagick/pythonmagick-0.8-r2.ebuild39
-rw-r--r--dev-python/pythonmagick/pythonmagick-0.9.1.ebuild10
3 files changed, 15 insertions, 43 deletions
diff --git a/dev-python/pythonmagick/ChangeLog b/dev-python/pythonmagick/ChangeLog
index 1169cc350158..4a11cd69a550 100644
--- a/dev-python/pythonmagick/ChangeLog
+++ b/dev-python/pythonmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pythonmagick
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythonmagick/ChangeLog,v 1.22 2009/11/28 15:19:36 josejx Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythonmagick/ChangeLog,v 1.23 2010/05/18 16:53:51 bicatali Exp $
+
+ 18 May 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -pythonmagick-0.8-r2.ebuild, pythonmagick-0.9.1.ebuild:
+ Removed .la file, now does not build static library, which is probably
+ useless. Removed old version
28 Nov 2009; Joseph Jezak <josejx@gentoo.org> pythonmagick-0.8-r2.ebuild,
pythonmagick-0.9.1.ebuild:
diff --git a/dev-python/pythonmagick/pythonmagick-0.8-r2.ebuild b/dev-python/pythonmagick/pythonmagick-0.8-r2.ebuild
deleted file mode 100644
index 388a99b44813..000000000000
--- a/dev-python/pythonmagick/pythonmagick-0.8-r2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythonmagick/pythonmagick-0.8-r2.ebuild,v 1.2 2009/11/28 15:19:36 josejx Exp $
-
-NEED_PYTHON=2.5
-EAPI=2
-inherit eutils python flag-o-matic autotools
-
-MY_PN=PythonMagick
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python bindings for ImageMagick"
-HOMEPAGE="http://www.imagemagick.org/script/api.php"
-SRC_URI="http://www.imagemagick.org/download/python/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND=">=media-gfx/imagemagick-6.4
- >=dev-libs/boost-1.34.0"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-PYTHON_MODNAME="${MY_PN}"
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- append-flags $(python-config --includes)
- export BOOST_PYTHON_LIB=boost_python
- epatch "${FILESDIR}"/${P}-python26.patch
- AT_M4DIR="m4" eautoreconf
-}
-
-src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/dev-python/pythonmagick/pythonmagick-0.9.1.ebuild b/dev-python/pythonmagick/pythonmagick-0.9.1.ebuild
index a488c9df084e..54176077e0fc 100644
--- a/dev-python/pythonmagick/pythonmagick-0.9.1.ebuild
+++ b/dev-python/pythonmagick/pythonmagick-0.9.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythonmagick/pythonmagick-0.9.1.ebuild,v 1.4 2009/11/28 15:19:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythonmagick/pythonmagick-0.9.1.ebuild,v 1.5 2010/05/18 16:53:51 bicatali Exp $
EAPI=2
inherit python flag-o-matic
@@ -30,7 +30,13 @@ pkg_setup() {
export BOOST_PYTHON_LIB=boost_python
}
+src_configure() {
+ # no need of static library for python module
+ econf --disable-static
+}
+
src_install() {
python_need_rebuild
emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"$(python_get_sitedir)/${MY_PN}/*.la
}