summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-08 01:14:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-08 01:14:40 +0000
commit488c12a7df1c35b278a50102b3aaead5c76fc6a7 (patch)
tree9efdc642d65f7b1eb4af2aa00ab08de41e7870fa /dev-python
parentverison bump 3.05 (diff)
downloadgentoo-2-488c12a7df1c35b278a50102b3aaead5c76fc6a7.tar.gz
gentoo-2-488c12a7df1c35b278a50102b3aaead5c76fc6a7.tar.bz2
gentoo-2-488c12a7df1c35b278a50102b3aaead5c76fc6a7.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 13946-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylibacl/ChangeLog8
-rw-r--r--dev-python/pylibacl/pylibacl-0.4.0-r1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/pylibacl/ChangeLog b/dev-python/pylibacl/ChangeLog
index 612e6668c432..f3ee50ea97b2 100644
--- a/dev-python/pylibacl/ChangeLog
+++ b/dev-python/pylibacl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylibacl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/ChangeLog,v 1.21 2009/06/01 16:11:09 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/ChangeLog,v 1.22 2009/08/08 01:14:40 arfrever Exp $
+
+*pylibacl-0.4.0-r1 (08 Aug 2009)
+
+ 08 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pylibacl-0.4.0-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
01 Jun 2009; nixnut <nixnut@gentoo.org> pylibacl-0.4.0.ebuild:
ppc stable #267214
diff --git a/dev-python/pylibacl/pylibacl-0.4.0-r1.ebuild b/dev-python/pylibacl/pylibacl-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..f1781e36f441
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.4.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/pylibacl-0.4.0-r1.ebuild,v 1.1 2009/08/08 01:14:40 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python interface to libacl"
+HOMEPAGE="http://sourceforge.net/projects/pylibacl/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/python
+ sys-apps/acl"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6_rc7-r1"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib*)" python test/test_acls.py || \
+ {
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ return 1
+ }
+ }
+ python_execute_function testing
+}