summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-05 05:57:23 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-05 05:57:23 +0000
commit3b0c3719d007c6c9bce6ed935ef8784f973031e2 (patch)
treee6f7068c74cbedfc369f602311bddb164acbe0f9 /dev-python
parentWhitespace (diff)
downloadgentoo-2-3b0c3719d007c6c9bce6ed935ef8784f973031e2.tar.gz
gentoo-2-3b0c3719d007c6c9bce6ed935ef8784f973031e2.tar.bz2
gentoo-2-3b0c3719d007c6c9bce6ed935ef8784f973031e2.zip
revbump, migrate -> distutils-r1, remove old
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/kid/ChangeLog11
-rw-r--r--dev-python/kid/kid-0.9.6-r1.ebuild46
-rw-r--r--dev-python/kid/kid-0.9.6.ebuild51
3 files changed, 54 insertions, 54 deletions
diff --git a/dev-python/kid/ChangeLog b/dev-python/kid/ChangeLog
index 2d5f2aa9f018..91f89ebc90a1 100644
--- a/dev-python/kid/ChangeLog
+++ b/dev-python/kid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/kid
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/ChangeLog,v 1.15 2009/10/10 17:24:44 grobian Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/ChangeLog,v 1.16 2013/06/05 05:57:23 idella4 Exp $
+
+*kid-0.9.6-r1 (05 Jun 2013)
+
+ 05 Jun 2013; Ian Delaney <idella4@gentoo.org> +kid-0.9.6-r1.ebuild,
+ -kid-0.9.6.ebuild:
+ revbump, migrate -> distutils-r1, remove old
10 Oct 2009; Fabian Groffen <grobian@gentoo.org> kid-0.9.6.ebuild:
Merge from Prefix
@@ -76,4 +82,3 @@
10 Nov 2005; Rob Cakebread <pythonhead@gentoo.org>
+files/kid-0.7.1-ezsetup-gentoo.patch, +metadata.xml, +kid-0.7.1.ebuild:
Initial commit.
-
diff --git a/dev-python/kid/kid-0.9.6-r1.ebuild b/dev-python/kid/kid-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..7a4827818831
--- /dev/null
+++ b/dev-python/kid/kid-0.9.6-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/kid-0.9.6-r1.ebuild,v 1.1 2013/06/05 05:57:23 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple and Pythonic XML template language"
+HOMEPAGE="http://www.kid-templating.org/ http://pypi.python.org/pypi/kid"
+SRC_URI="http://www.kid-templating.org/dist/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS=( README doc/{guide.txt,index.txt,notes.txt} )
+
+python_prepare_all() {
+ use test && DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc
+}
+
+python_test() {
+ py.test -xl || die
+}
+
+python_install_all() {
+# dobin bin/*
+
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/kid/kid-0.9.6.ebuild b/dev-python/kid/kid-0.9.6.ebuild
deleted file mode 100644
index bfd7e5ad1822..000000000000
--- a/dev-python/kid/kid-0.9.6.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kid/kid-0.9.6.ebuild,v 1.4 2010/04/04 16:24:31 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-DESCRIPTION="A simple and Pythonic XML template language"
-HOMEPAGE="http://www.kid-templating.org/ http://pypi.python.org/pypi/kid"
-SRC_URI="http://www.kid-templating.org/dist/${PV}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="doc examples"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools
- doc? ( dev-python/docutils )"
-RESTRICT_PYTHON_ABIS="3.*"
-
-DOCS="HISTORY RELEASING"
-
-src_compile() {
- distutils_src_compile
- use doc && emake -C doc
-}
-
-src_test() {
- testing() {
- PYTHONPATH="." "$(PYTHON)" run_tests.py -x
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- dobin bin/*
-
- dodoc doc/*.txt
- use doc && dohtml doc/*.{html,css}
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}