summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-23 07:33:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-23 07:33:25 +0000
commit52d8236c296ee3cc0072c16fe14009f20f2aa266 (patch)
treea67f587bb4e4e0a3e8c22fbea7dfdd206510d834 /dev-python/wsgiproxy2
parentIntroduce multilib_get_enabled_abi_pairs() to obtain list containing both ABI... (diff)
downloadgentoo-2-52d8236c296ee3cc0072c16fe14009f20f2aa266.tar.gz
gentoo-2-52d8236c296ee3cc0072c16fe14009f20f2aa266.tar.bz2
gentoo-2-52d8236c296ee3cc0072c16fe14009f20f2aa266.zip
drop py2.6, add IUSE doc, doc build, fix everything
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/wsgiproxy2')
-rw-r--r--dev-python/wsgiproxy2/ChangeLog5
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild33
2 files changed, 26 insertions, 12 deletions
diff --git a/dev-python/wsgiproxy2/ChangeLog b/dev-python/wsgiproxy2/ChangeLog
index b610685f6483..44d21423291f 100644
--- a/dev-python/wsgiproxy2/ChangeLog
+++ b/dev-python/wsgiproxy2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/wsgiproxy2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiproxy2/ChangeLog,v 1.6 2014/01/08 02:43:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiproxy2/ChangeLog,v 1.7 2014/05/23 07:33:25 idella4 Exp $
+
+ 23 May 2014; Ian Delaney <idella4@gentoo.org> wsgiproxy2-0.4.1.ebuild:
+ drop py2.6, add IUSE doc, doc build, fix everything
*wsgiproxy2-0.4.1 (08 Jan 2014)
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild
index 4d2a54e1039e..65cd21e5617a 100644
--- a/dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild,v 1.1 2014/01/08 02:43:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild,v 1.2 2014/05/23 07:33:25 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-# this looks quite unpossible to run
-RESTRICT="test"
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
inherit distutils-r1
@@ -20,19 +17,33 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE="doc test"
-RDEPEND="dev-python/urllib3
- dev-python/socketpool[${PYTHON_USEDEP}]
+RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
- dev-python/restkit
dev-python/webob[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/webtest[${PYTHON_USEDEP}] )"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/webtest[${PYTHON_USEDEP}]
+ dev-python/socketpool[${PYTHON_USEDEP}]
+ dev-python/restkit[$(python_gen_usedep python2_7)] )"
+# Tests needing restkit are skipped under py3
S="${WORKDIR}/${MY_PN}-${PV}"
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+# this was always possible
python_test() {
nosetests || die "Tests fail with ${EPYTHON}"
}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}