summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-06-03 05:53:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-06-03 05:53:03 +0000
commit27c4eacc5ec5335c59de054dee950b778550b6a6 (patch)
treec5aead3af0f8a53328f43549a67ae8b17d644531 /dev-python/wsgiproxy2
parentBump (diff)
downloadgentoo-2-27c4eacc5ec5335c59de054dee950b778550b6a6.tar.gz
gentoo-2-27c4eacc5ec5335c59de054dee950b778550b6a6.tar.bz2
gentoo-2-27c4eacc5ec5335c59de054dee950b778550b6a6.zip
Bump
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/wsgiproxy2')
-rw-r--r--dev-python/wsgiproxy2/ChangeLog7
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/wsgiproxy2/ChangeLog b/dev-python/wsgiproxy2/ChangeLog
index 6f53d74492fa..7a9a5289933d 100644
--- a/dev-python/wsgiproxy2/ChangeLog
+++ b/dev-python/wsgiproxy2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wsgiproxy2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiproxy2/ChangeLog,v 1.3 2013/05/22 06:42:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiproxy2/ChangeLog,v 1.4 2013/06/03 05:53:03 patrick Exp $
+
+*wsgiproxy2-0.2 (03 Jun 2013)
+
+ 03 Jun 2013; Patrick Lauer <patrick@gentoo.org> +wsgiproxy2-0.2.ebuild:
+ Bump
22 May 2013; Patrick Lauer <patrick@gentoo.org> wsgiproxy2-0.1.ebuild:
Readding python-3.3 to python_targets
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.2.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.2.ebuild
new file mode 100644
index 000000000000..87980f26efdf
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiproxy2/wsgiproxy2-0.2.ebuild,v 1.1 2013/06/03 05:53:03 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+# this looks quite unpossible to run
+RESTRICT="test"
+
+inherit distutils-r1
+
+MY_PN="WSGIProxy2"
+
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="http://pythonpaste.org/wsgiproxy/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/urllib3
+ dev-python/socketpool[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/restkit
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/webtest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}