summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-29 01:45:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-29 01:45:40 +0000
commit63dba5f24b1eb83b210abc4d5900cd01f994b6f3 (patch)
tree7907ca19fb54190f9b9d0a09209e7198a1fbce62 /dev-python/webtest
parentDelete older ebuild. (diff)
downloadgentoo-2-63dba5f24b1eb83b210abc4d5900cd01f994b6f3.tar.gz
gentoo-2-63dba5f24b1eb83b210abc4d5900cd01f994b6f3.tar.bz2
gentoo-2-63dba5f24b1eb83b210abc4d5900cd01f994b6f3.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14458-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog6
-rw-r--r--dev-python/webtest/webtest-1.2.ebuild18
2 files changed, 18 insertions, 6 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index 412591095697..c21283e7532d 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/webtest
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.3 2009/09/04 15:07:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.4 2009/09/29 01:45:40 arfrever Exp $
+
+ 29 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ webtest-1.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*webtest-1.2 (04 Sep 2009)
diff --git a/dev-python/webtest/webtest-1.2.ebuild b/dev-python/webtest/webtest-1.2.ebuild
index 4f942d0ed9dd..f66d6a55362c 100644
--- a/dev-python/webtest/webtest-1.2.ebuild
+++ b/dev-python/webtest/webtest-1.2.ebuild
@@ -1,6 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.2.ebuild,v 1.1 2009/09/04 15:07:03 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.2.ebuild,v 1.2 2009/09/29 01:45:40 arfrever Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -10,14 +15,17 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Helper to test WSGI applications"
HOMEPAGE="http://pythonpaste.org/webtest/"
SRC_URI="http://pypi.python.org/packages/source/W/${MY_PN}/${MY_P}.tar.gz"
+
LICENSE="MIT"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="doc examples"
-S="${WORKDIR}/${MY_P}"
+
DEPEND="dev-python/setuptools"
-RDEPEND="|| ( >=dev-python/wsgiref-0.1.2 >=dev-lang/python-2.5.2-r4 )
- >=dev-python/webob-0.9.2"
+RDEPEND=">=dev-python/webob-0.9.2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
src_install() {
distutils_src_install