summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 14:08:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 14:08:25 +0000
commit037ccd29da63bda8f00c9de0f55d44c3a8f9d35a (patch)
treec249403aa19d351052ce26964d657d0123ebb4d8 /dev-python/webtest
parentBump to 0.9.6, adding ~amd64 keyword (diff)
downloadgentoo-2-037ccd29da63bda8f00c9de0f55d44c3a8f9d35a.tar.gz
gentoo-2-037ccd29da63bda8f00c9de0f55d44c3a8f9d35a.tar.bz2
gentoo-2-037ccd29da63bda8f00c9de0f55d44c3a8f9d35a.zip
Bump to 1.1, adding ~amd64 keyword
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog9
-rw-r--r--dev-python/webtest/webtest-1.1.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index 2c0bf1b616ff..31c55226a37c 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webtest
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.1 2008/07/02 05:19:59 pythonhead Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.2 2009/02/15 14:08:25 patrick Exp $
+
+*webtest-1.1 (15 Feb 2009)
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org> +webtest-1.1.ebuild:
+ Bump to 1.1, adding ~amd64 keyword
*webtest-1.0 (02 Jul 2008)
diff --git a/dev-python/webtest/webtest-1.1.ebuild b/dev-python/webtest/webtest-1.1.ebuild
new file mode 100644
index 000000000000..e3db4b562a39
--- /dev/null
+++ b/dev-python/webtest/webtest-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.1.ebuild,v 1.1 2009/02/15 14:08:25 patrick Exp $
+
+inherit distutils
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/"
+SRC_URI="http://pypi.python.org/packages/source/W/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="doc examples"
+S="${WORKDIR}/${MY_P}"
+DEPEND="dev-python/setuptools"
+RDEPEND="|| ( >=dev-python/wsgiref-0.1.2 >=dev-lang/python-2.5.2-r4 )
+ >=dev-python/webob-0.9.2"
+
+src_install() {
+ distutils_src_install
+
+ use doc && dodoc docs/index.txt
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r docs/chipy-presentation
+ fi
+}