summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-21 10:59:53 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-21 10:59:53 +0000
commit46ed0672e01c237271eb02749cc56119b4e3ee12 (patch)
treee80decae8b632ec10f9bc649a84a1de8738de397 /dev-python/webpy
parentdev-python/shiboken: python-r1 getter are EPREFIXed (diff)
downloadgentoo-2-46ed0672e01c237271eb02749cc56119b4e3ee12.tar.gz
gentoo-2-46ed0672e01c237271eb02749cc56119b4e3ee12.tar.bz2
gentoo-2-46ed0672e01c237271eb02749cc56119b4e3ee12.zip
migration revbump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/webpy')
-rw-r--r--dev-python/webpy/ChangeLog9
-rw-r--r--dev-python/webpy/webpy-0.37-r1.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/webpy/ChangeLog b/dev-python/webpy/ChangeLog
index 5afa484db945..c1bd70db3bb7 100644
--- a/dev-python/webpy/ChangeLog
+++ b/dev-python/webpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webpy
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.29 2012/10/17 05:24:07 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/ChangeLog,v 1.30 2013/03/21 10:59:53 idella4 Exp $
+
+*webpy-0.37-r1 (21 Mar 2013)
+
+ 21 Mar 2013; Ian Delaney <idella4@gentoo.org> +webpy-0.37-r1.ebuild:
+ migration revbump
17 Oct 2012; Patrick Lauer <patrick@gentoo.org> webpy-0.37.ebuild:
Restricting jython
diff --git a/dev-python/webpy/webpy-0.37-r1.ebuild b/dev-python/webpy/webpy-0.37-r1.ebuild
new file mode 100644
index 000000000000..9e1a157bda1c
--- /dev/null
+++ b/dev-python/webpy/webpy-0.37-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webpy/webpy-0.37-r1.ebuild,v 1.1 2013/03/21 10:59:53 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN="web.py"
+
+DESCRIPTION="A small and simple web framework for Python"
+HOMEPAGE="http://www.webpy.org http://pypi.python.org/pypi/web.py"
+SRC_URI="http://www.webpy.org/static/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/web.py-${PV}"
+
+python_test() {
+ local return_status="0" test tests="db http net template utils"
+ for test in ${tests}; do
+ echo "Running doctests in ${test}.py..."
+ "${PYTHON}" web/${test}.py || return_status="$?"
+ done
+ return "${return_status}"
+}