summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Kingsley <tercel@gentoo.org>2005-12-22 01:21:38 +0000
committerColin Kingsley <tercel@gentoo.org>2005-12-22 01:21:38 +0000
commitfbf28552e1dcb86e979cc8da401341f0cb4f4f1f (patch)
treedeeb84ed2b0e3131ac6bb7e3947d2090c9c1cef9 /dev-python/visual
parentStable on x86; bug #106911 (diff)
downloadgentoo-2-fbf28552e1dcb86e979cc8da401341f0cb4f4f1f.tar.gz
gentoo-2-fbf28552e1dcb86e979cc8da401341f0cb4f4f1f.tar.bz2
gentoo-2-fbf28552e1dcb86e979cc8da401341f0cb4f4f1f.zip
new version to ~x86
(Portage version: 2.0.53)
Diffstat (limited to 'dev-python/visual')
-rw-r--r--dev-python/visual/ChangeLog11
-rw-r--r--dev-python/visual/Manifest16
-rw-r--r--dev-python/visual/files/digest-visual-3.2.51
-rw-r--r--dev-python/visual/visual-3.2.5.ebuild66
4 files changed, 79 insertions, 15 deletions
diff --git a/dev-python/visual/ChangeLog b/dev-python/visual/ChangeLog
index 52dd4a5ed914..f4ca84310a4d 100644
--- a/dev-python/visual/ChangeLog
+++ b/dev-python/visual/ChangeLog
@@ -1,15 +1,20 @@
# ChangeLog for dev-python/visual
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.3 2005/09/11 23:34:26 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.4 2005/12/22 01:21:38 tercel Exp $
+
+*visual-3.2.5 (22 Dec 2005)
+
+ 22 Dec 2005; <tercel@gentoo.org> +visual-3.2.5.ebuild:
+ commit new version to ~x86
11 Sep 2005; Jonathan Smith <smithj@gentoo.org> visual-3.2.1.ebuild:
fixed dependency... changed >=gtkglarea-1.2 to =1.2*
- 13 Jul 2005; <colin@gentoo.org> visual-3.2.1.ebuild:
+ 13 Jul 2005; <tercel@gentoo.org> visual-3.2.1.ebuild:
3.2.1 moved to stable on x86
*visual-3.2.1 (01 Jun 2005)
- 01 Jun 2005; <colin@gentoo.org> +metadata.xml, +visual-3.2.1.ebuild:
+ 01 Jun 2005; <tercel@gentoo.org> +metadata.xml, +visual-3.2.1.ebuild:
Initial commit.
diff --git a/dev-python/visual/Manifest b/dev-python/visual/Manifest
index 6f5258b087cd..976463698ab8 100644
--- a/dev-python/visual/Manifest
+++ b/dev-python/visual/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 4c134cf76fb56f1537a9e92019bde6c0 visual-3.2.1.ebuild 1753
MD5 abdc4542d3cbb0948c0b82ea3fc5729f ChangeLog 540
-MD5 dc0b1d0f6421b62d34ca91dd8ac2d52d metadata.xml 255
MD5 6d6e6100c2055b0082f7ddbee8f2d1e2 files/digest-visual-3.2.1 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDJL8Sl5AvwDPiUowRApYzAJ9TSqR5iX3taGaa+FnAKuo6sAuDeACgo+eA
-dO/tP1fmqPH+u4NSN6fJNaM=
-=bKie
------END PGP SIGNATURE-----
+MD5 98c0685166e7c2d0b7bfc23647846c14 files/digest-visual-3.2.5 65
+MD5 dc0b1d0f6421b62d34ca91dd8ac2d52d metadata.xml 255
+MD5 4c134cf76fb56f1537a9e92019bde6c0 visual-3.2.1.ebuild 1753
+MD5 4c134cf76fb56f1537a9e92019bde6c0 visual-3.2.5.ebuild 1753
diff --git a/dev-python/visual/files/digest-visual-3.2.5 b/dev-python/visual/files/digest-visual-3.2.5
new file mode 100644
index 000000000000..dcc696a819ff
--- /dev/null
+++ b/dev-python/visual/files/digest-visual-3.2.5
@@ -0,0 +1 @@
+MD5 a4a56d8db402e101c159522340515d4b visual-3.2.5.tar.bz2 412832
diff --git a/dev-python/visual/visual-3.2.5.ebuild b/dev-python/visual/visual-3.2.5.ebuild
new file mode 100644
index 000000000000..df08e1874639
--- /dev/null
+++ b/dev-python/visual/visual-3.2.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-3.2.5.ebuild,v 1.1 2005/12/22 01:21:38 tercel Exp $
+
+inherit distutils
+
+DESCRIPTION="An easy to use Real-time 3D graphics library for Python."
+SRC_URI="http://www.vpython.org/download/${PN}-${PV}.tar.bz2"
+HOMEPAGE="http://www.vpython.org/"
+
+IUSE="doc examples numeric numarray"
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="visual"
+
+DEPEND=">=dev-lang/python-2.3
+ virtual/opengl
+ =x11-libs/gtk+-1.2*
+ =x11-libs/gtkglarea-1.2*
+ dev-util/pkgconfig
+ >=dev-libs/boost-1.31
+ numeric? ( dev-python/numeric )
+ numarray? ( >=dev-python/numarray-1.0 )
+ !numeric? ( !numarray? ( dev-python/numeric ) )"
+
+src_compile() {
+ local myconf="--without-numarray --without-numeric"
+
+ echo
+ if useq numeric; then
+ einfo "Building with Numeric support"
+ myconf=${myconf/--without-numeric}
+ fi
+ if useq numarray; then
+ einfo "Building with Numarray support"
+ myconf=${myconf/--without-numarray}
+ fi
+ if ! useq numeric && ! useq numarray; then
+ einfo "Support for Numeric or Numarray was not specified."
+ einfo "Building with Numeric support"
+ myconf=${myconf/--without-numeric}
+ fi
+ echo
+
+ econf \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-example-dir=/usr/share/doc/${PF}/examples \
+ $(use_enable doc docs ) \
+ $(use_enable examples ) \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ python_version
+
+ mv ${D}/usr/lib/python${PYVER}/site-packages/cvisualmodule* \
+ ${D}/usr/lib/python${PYVER}/site-packages/visual
+
+ #the vpython script does not work, and is unnecessary
+ rm ${D}/usr/bin/vpython
+}