summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-08 03:47:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-08 03:47:50 +0000
commit6b88ccdb42f42493f2233144cb1956a678f5b18c (patch)
tree52b75b122d6efc8286d2551f68c7598e30e8cdd7 /dev-python/visual
parentSecurity bump, include hunspell fix for dictionaries (diff)
downloadgentoo-2-6b88ccdb42f42493f2233144cb1956a678f5b18c.tar.gz
gentoo-2-6b88ccdb42f42493f2233144cb1956a678f5b18c.tar.bz2
gentoo-2-6b88ccdb42f42493f2233144cb1956a678f5b18c.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/visual')
-rw-r--r--dev-python/visual/ChangeLog8
-rw-r--r--dev-python/visual/visual-5.3.1.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-python/visual/ChangeLog b/dev-python/visual/ChangeLog
index cdf130ab105a..b85799284cb7 100644
--- a/dev-python/visual/ChangeLog
+++ b/dev-python/visual/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/visual
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.36 2010/04/05 17:11:20 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.37 2010/04/08 03:47:50 arfrever Exp $
+
+*visual-5.3.1 (08 Apr 2010)
+
+ 08 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +visual-5.3.1.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
*visual-5.1.3 (05 Apr 2010)
diff --git a/dev-python/visual/visual-5.3.1.ebuild b/dev-python/visual/visual-5.3.1.ebuild
new file mode 100644
index 000000000000..5934553f4aef
--- /dev/null
+++ b/dev-python/visual/visual-5.3.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.3.1.ebuild,v 1.1 2010/04/08 03:47:50 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit eutils flag-o-matic python versionator
+
+MY_P="${PN}-$(delete_version_separator 2)_release"
+
+DESCRIPTION="Real-time 3D graphics library for Python"
+HOMEPAGE="http://www.vpython.org/"
+SRC_URI="http://www.vpython.org/contents/download/${MY_P}.tar.bz2"
+
+IUSE="doc examples"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="visual"
+
+RDEPEND=">=dev-libs/boost-1.41.0[python]
+ dev-cpp/libglademm
+ >=dev-cpp/gtkglextmm-1.2
+ dev-python/numpy"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.41.0")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ # We have to use a hack here because the build system doesn't provide a way to specify
+ # the include and lib directory for boost.
+ append-cxxflags -I${BOOST_INC}
+ append-ldflags -L${BOOST_LIB}
+
+ python_execute_function -d -s -- \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-example-dir=/usr/share/doc/${PF}/examples \
+ $(use_enable doc docs) \
+ $(use_enable examples)
+}
+
+src_install() {
+ python_src_install
+ python_clean_sitedirs
+
+ dodoc authors.txt HACKING.txt NEWS.txt || die "dodoc failed"
+
+ # Don't install useless vpython script.
+ rm -fr "${ED}/usr/bin"
+}
+
+pkg_postinst() {
+ python_mod_optimize visual
+}
+
+pkg_postrm() {
+ python_mod_cleanup visual
+}