summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-08 16:57:17 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-08 16:57:17 +0000
commit5d836508baadab54f58fce631b80828413e76e51 (patch)
tree5b2f7f1ee401f42fca70366fb3bdc77bb3a80e28 /dev-python/visual
parentVersion bump (diff)
downloadgentoo-2-5d836508baadab54f58fce631b80828413e76e51.tar.gz
gentoo-2-5d836508baadab54f58fce631b80828413e76e51.tar.bz2
gentoo-2-5d836508baadab54f58fce631b80828413e76e51.zip
Version bump.
(Portage version: 2.2.0_alpha7_p5/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/visual')
-rw-r--r--dev-python/visual/ChangeLog8
-rw-r--r--dev-python/visual/visual-5.4.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-python/visual/ChangeLog b/dev-python/visual/ChangeLog
index 3fbfcc6bc03f..884da0a3fc6e 100644
--- a/dev-python/visual/ChangeLog
+++ b/dev-python/visual/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/visual
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.43 2010/06/06 09:13:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/ChangeLog,v 1.44 2010/12/08 16:57:17 arfrever Exp $
+
+*visual-5.4 (08 Dec 2010)
+
+ 08 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +visual-5.4.ebuild:
+ Version bump.
06 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> visual-5.3.2.ebuild:
x86 stable wrt bug #319167
diff --git a/dev-python/visual/visual-5.4.ebuild b/dev-python/visual/visual-5.4.ebuild
new file mode 100644
index 000000000000..ce07bafeb239
--- /dev/null
+++ b/dev-python/visual/visual-5.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/visual/visual-5.4.ebuild,v 1.1 2010/12/08 16:57:17 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit flag-o-matic python versionator
+
+MY_P="${PN}-$(delete_version_separator 2)_release"
+
+DESCRIPTION="Real-time 3D graphics library for Python"
+HOMEPAGE="http://www.vpython.org/"
+SRC_URI="http://www.vpython.org/contents/download/${MY_P}.tar.bz2"
+
+IUSE="doc examples"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="visual"
+
+RDEPEND=">=dev-libs/boost-1.41.0[python]
+ dev-cpp/libglademm
+ >=dev-cpp/gtkglextmm-1.2
+ dev-python/numpy"
+# dev-python/polygon
+# >=dev-python/ttfquery-1.0.4
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ echo "#!/bin/bash" > py-compile
+ python_src_prepare
+}
+
+src_configure() {
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.41.0")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+ # We have to use a hack here because the build system doesn't provide a way to specify
+ # the include and lib directory for boost.
+ append-cxxflags -I${BOOST_INC}
+ append-ldflags -L${BOOST_LIB}
+
+ python_src_configure \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-example-dir=/usr/share/doc/${PF}/examples \
+ $(use_enable doc docs) \
+ $(use_enable examples)
+}
+
+src_install() {
+ python_src_install
+ python_clean_installation_image
+
+ dodoc authors.txt HACKING.txt NEWS.txt || die "dodoc failed"
+
+ # Don't install useless vpython script.
+ rm -fr "${ED}usr/bin"
+}
+
+pkg_postinst() {
+ python_mod_optimize vis visual
+}
+
+pkg_postrm() {
+ python_mod_cleanup vis visual
+}