summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2009-04-19 12:28:43 +0000
committerCaleb Tennis <caleb@gentoo.org>2009-04-19 12:28:43 +0000
commit408ab1bfa2679cd28e92c6cabc2a86385afa91bc (patch)
tree3c8a7fababa34e7c3f1b1d72a6cc3e0b0e4c2089 /dev-python/uuid
parentInitial import (diff)
downloadgentoo-2-408ab1bfa2679cd28e92c6cabc2a86385afa91bc.tar.gz
gentoo-2-408ab1bfa2679cd28e92c6cabc2a86385afa91bc.tar.bz2
gentoo-2-408ab1bfa2679cd28e92c6cabc2a86385afa91bc.zip
Initial import
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'dev-python/uuid')
-rw-r--r--dev-python/uuid/ChangeLog10
-rw-r--r--dev-python/uuid/metadata.xml8
-rw-r--r--dev-python/uuid/uuid-1.30.ebuild23
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/uuid/ChangeLog b/dev-python/uuid/ChangeLog
new file mode 100644
index 000000000000..a8ba471bf73c
--- /dev/null
+++ b/dev-python/uuid/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/uuid
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/uuid/ChangeLog,v 1.1 2009/04/19 12:28:43 caleb Exp $
+
+*uuid-1.30 (19 Apr 2009)
+
+ 19 Apr 2009; Caleb Tennis <caleb@gentoo.org +metadata.xml,
+ +uuid-1.30.ebuild:
+ Initial import
+
diff --git a/dev-python/uuid/metadata.xml b/dev-python/uuid/metadata.xml
new file mode 100644
index 000000000000..9167772c5c2f
--- /dev/null
+++ b/dev-python/uuid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>caleb@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/uuid/uuid-1.30.ebuild b/dev-python/uuid/uuid-1.30.ebuild
new file mode 100644
index 000000000000..833c24eeb741
--- /dev/null
+++ b/dev-python/uuid/uuid-1.30.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/uuid/uuid-1.30.ebuild,v 1.1 2009/04/19 12:28:43 caleb Exp $
+
+inherit distutils
+
+DESCRIPTION="UUID object and generation functions"
+HOMEPAGE="http://pypi.python.org/pypi/${PN}/${PV}"
+SRC_URI="http://pypi.python.org/packages/source/u/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.3"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+src_install() {
+ distutils_src_install
+}
+