summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-01-06 21:19:11 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-01-06 21:19:11 +0000
commit7321edc1e7e44381d8e23b6840f55a710bbd20e7 (patch)
treee6e51166be52d9c644e748f99b3c4ed2d18a9688 /dev-python/utidylib
parentnet-analyzer/tcpick removal (pending 04th December 2006), see #125491 for ref... (diff)
downloadgentoo-2-7321edc1e7e44381d8e23b6840f55a710bbd20e7.tar.gz
gentoo-2-7321edc1e7e44381d8e23b6840f55a710bbd20e7.tar.bz2
gentoo-2-7321edc1e7e44381d8e23b6840f55a710bbd20e7.zip
Fixed several issues (tests, modname, dependencies)
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/ChangeLog8
-rw-r--r--dev-python/utidylib/files/digest-utidylib-0.22
-rw-r--r--dev-python/utidylib/files/utidylib-0.2-fix_tests.patch31
-rw-r--r--dev-python/utidylib/utidylib-0.2.ebuild17
4 files changed, 47 insertions, 11 deletions
diff --git a/dev-python/utidylib/ChangeLog b/dev-python/utidylib/ChangeLog
index 67f8c3a07e4e..9edb1aa08345 100644
--- a/dev-python/utidylib/ChangeLog
+++ b/dev-python/utidylib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/utidylib
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/utidylib/ChangeLog,v 1.4 2006/10/15 12:54:37 tcort Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/utidylib/ChangeLog,v 1.5 2007/01/06 21:19:11 dev-zero Exp $
+
+ 06 Jan 2007; Tiziano Müller <dev-zero@gentoo.org>
+ +files/utidylib-0.2-fix_tests.patch, utidylib-0.2.ebuild:
+ Fixed several issues (tests, modname, dependencies)
15 Oct 2006; Thomas Cort <tcort@gentoo.org> utidylib-0.2.ebuild:
Added ~amd64 keyword wrt Bug #147370.
diff --git a/dev-python/utidylib/files/digest-utidylib-0.2 b/dev-python/utidylib/files/digest-utidylib-0.2
index 4519fa1fa97d..779534af6e83 100644
--- a/dev-python/utidylib/files/digest-utidylib-0.2
+++ b/dev-python/utidylib/files/digest-utidylib-0.2
@@ -1 +1,3 @@
MD5 c9f16988f92ef660f46523192ef37462 uTidylib-0.2.zip 17575
+RMD160 c0a80ced37ea93e678ba80bf1d5b18c93506719c uTidylib-0.2.zip 17575
+SHA256 0385b29b0e636fa1cc6eb86ecb5428cf399f9474c8f343af038afce59720a333 uTidylib-0.2.zip 17575
diff --git a/dev-python/utidylib/files/utidylib-0.2-fix_tests.patch b/dev-python/utidylib/files/utidylib-0.2-fix_tests.patch
new file mode 100644
index 000000000000..319430134910
--- /dev/null
+++ b/dev-python/utidylib/files/utidylib-0.2-fix_tests.patch
@@ -0,0 +1,31 @@
+--- tidy/test_tidy.py.orig 2007-01-06 21:43:08.000000000 +0100
++++ tidy/test_tidy.py 2007-01-06 21:43:27.000000000 +0100
+@@ -20,8 +20,8 @@
+ def defaultDocs(self):
+ doc1 = tidy.parseString(self.input1)
+ doc2 = tidy.parseString(self.input2)
+- doc3 = tidy.parse("foo.htm")
+- doc4 = tidy.parse("bar.htm") # doesn't exist
++ doc3 = tidy.parse("../foo.htm")
++ doc4 = tidy.parse("../bar.htm") # doesn't exist
+ return (doc1, doc2, doc3, doc4)
+ def test_badOptions(self):
+ badopts = [{'foo': 1}, {'indent': '---'}, {'indent_spaces': None}]
+@@ -34,7 +34,7 @@
+ self.fail("Invalid option %s should have raised an error" %
+ repr(dct))
+ def test_encodings(self):
+- foo = file('foo.htm').read().decode('utf8').encode('ascii',
++ foo = file('../foo.htm').read().decode('utf8').encode('ascii',
+ 'xmlcharrefreplace')
+ doc1u = tidy.parseString(foo, input_encoding='ascii',
+ output_encoding='latin1')
+@@ -59,7 +59,7 @@
+ ## self.failIf(len(doc2.errors)>1) # FIXME - tidylib doesn't
+ ## # support this?
+ self.failUnless(str(doc2).find('\n')<0)
+- doc3 = tidy.parse('foo.htm', char_encoding='utf8',
++ doc3 = tidy.parse('../foo.htm', char_encoding='utf8',
+ alt_text='foo')
+ self.failUnless(str(doc3).find('alt="foo"')>=0)
+ self.failUnless(str(doc3).find('\xc3\xa9')>=0)
diff --git a/dev-python/utidylib/utidylib-0.2.ebuild b/dev-python/utidylib/utidylib-0.2.ebuild
index a9e1242afc3d..aaac63b6d4bd 100644
--- a/dev-python/utidylib/utidylib-0.2.ebuild
+++ b/dev-python/utidylib/utidylib-0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/utidylib/utidylib-0.2.ebuild,v 1.4 2006/10/15 12:54:37 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/utidylib/utidylib-0.2.ebuild,v 1.5 2007/01/06 21:19:11 dev-zero Exp $
inherit distutils eutils
@@ -16,14 +16,14 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc test"
RDEPEND=">=dev-lang/python-2.3
- dev-python/ctypes
- app-text/htmltidy"
-
+ app-text/htmltidy
+ dev-python/ctypes"
DEPEND="${RDEPEND}
app-arch/unzip
doc? ( dev-python/epydoc )
test? ( dev-python/twisted )"
+PYTHON_MODNAME="tidy"
S="${WORKDIR}/${MY_P}"
src_unpack() {
@@ -31,6 +31,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-tests-twisted-2.1-compat.patch"
epatch "${FILESDIR}/${P}-no-docs-in-site-packages.patch"
+ epatch "${FILESDIR}/${P}-fix_tests.patch"
}
src_compile() {
@@ -41,12 +42,10 @@ src_compile() {
}
src_test() {
- trial tidy/test_tidy.py || die "tests failed"
+ trial tidy || die "tests failed"
}
src_install() {
distutils_src_install
- if use doc; then
- dohtml -r apidoc
- fi
+ use doc && dohtml -r apidoc
}