summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-04-09 08:48:40 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-04-09 08:48:40 +0000
commit3bc22fec82c9e97196cbc0d3387d3626b1fafb46 (patch)
tree9a411c74694b1d079ea556b872febf2c3bc33716 /dev-python/unittest2
parentStable on amd64 wrt bug #299826 (diff)
downloadgentoo-2-3bc22fec82c9e97196cbc0d3387d3626b1fafb46.tar.gz
gentoo-2-3bc22fec82c9e97196cbc0d3387d3626b1fafb46.tar.bz2
gentoo-2-3bc22fec82c9e97196cbc0d3387d3626b1fafb46.zip
Version bump dev-python/unittest2 to 0.4.0.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/unittest2')
-rw-r--r--dev-python/unittest2/ChangeLog8
-rw-r--r--dev-python/unittest2/unittest2-0.4.0.ebuild (renamed from dev-python/unittest2/unittest2-0.3.0.ebuild)9
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-python/unittest2/ChangeLog b/dev-python/unittest2/ChangeLog
index ae9f9bc18097..a9170b1d16e2 100644
--- a/dev-python/unittest2/ChangeLog
+++ b/dev-python/unittest2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/unittest2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/ChangeLog,v 1.2 2010/03/26 17:15:54 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/ChangeLog,v 1.3 2010/04/09 08:48:40 djc Exp $
+
+*unittest2-0.4.0 (09 Apr 2010)
+
+ 09 Apr 2010; Dirkjan Ochtman <djc@gentoo.org> -unittest2-0.3.0.ebuild,
+ +unittest2-0.4.0.ebuild:
+ Version bump to 0.4, fix tests.
*unittest2-0.3.0 (26 Mar 2010)
diff --git a/dev-python/unittest2/unittest2-0.3.0.ebuild b/dev-python/unittest2/unittest2-0.4.0.ebuild
index 1fe3c920a3e2..bf92c07f748c 100644
--- a/dev-python/unittest2/unittest2-0.3.0.ebuild
+++ b/dev-python/unittest2/unittest2-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/unittest2-0.3.0.ebuild,v 1.1 2010/03/26 17:15:54 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/unittest2-0.4.0.ebuild,v 1.1 2010/04/09 08:48:40 djc Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -22,3 +22,10 @@ RDEPEND=""
RESTRICT_PYTHON_ABIS="3.*"
DOCS="README.txt"
+
+src_test() {
+ testing() {
+ ./unit2 discover
+ }
+ python_execute_function testing
+}