summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-07 17:47:51 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-07 17:47:51 +0000
commit3bc0762c6624749c2392f282384669cd007fd43a (patch)
tree31f8262d8c15652151fda9cc2c82898f067e2045 /dev-python/unittest2
parentOld. (diff)
downloadgentoo-2-3bc0762c6624749c2392f282384669cd007fd43a.tar.gz
gentoo-2-3bc0762c6624749c2392f282384669cd007fd43a.tar.bz2
gentoo-2-3bc0762c6624749c2392f282384669cd007fd43a.zip
Fix compatibility with distutils_src_install().
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/unittest2')
-rw-r--r--dev-python/unittest2/unittest2-0.5.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/unittest2/unittest2-0.5.1.ebuild b/dev-python/unittest2/unittest2-0.5.1.ebuild
index 8c0430b9ee40..f232ba79b488 100644
--- a/dev-python/unittest2/unittest2-0.5.1.ebuild
+++ b/dev-python/unittest2/unittest2-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/unittest2-0.5.1.ebuild,v 1.10 2011/01/07 00:43:31 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/unittest2-0.5.1.ebuild,v 1.11 2011/01/07 17:47:51 arfrever Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -31,6 +31,9 @@ src_prepare() {
else
cp -pr "${S}" "${S}-${PYTHON_ABI}" || return 1
fi
+
+ # Disable versioning of unit2 script to avoid collision with versioning performed by distutils_src_install().
+ sed -e "/'%s = unittest2:main_' % SCRIPT2,/d" -i "${S}-${PYTHON_ABI}/setup.py" || return 1
}
python_execute_function -q preparation
}