summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-06-16 04:26:23 +0000
committerJeroen Roovers <jer@gentoo.org>2015-06-16 04:26:23 +0000
commit8819608ee03458d146798765c525e633797cc85c (patch)
tree690b9d70c2dae4ed03b282f78564a712310930e9 /dev-python/unidecode
parentVersion bump. (diff)
downloadgentoo-2-8819608ee03458d146798765c525e633797cc85c.tar.gz
gentoo-2-8819608ee03458d146798765c525e633797cc85c.tar.bz2
gentoo-2-8819608ee03458d146798765c525e633797cc85c.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-python/unidecode')
-rw-r--r--dev-python/unidecode/ChangeLog7
-rw-r--r--dev-python/unidecode/unidecode-0.04.18.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/unidecode/ChangeLog b/dev-python/unidecode/ChangeLog
index 7c834db18240..c3e9d6ffda18 100644
--- a/dev-python/unidecode/ChangeLog
+++ b/dev-python/unidecode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/unidecode
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/unidecode/ChangeLog,v 1.40 2015/06/04 07:28:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unidecode/ChangeLog,v 1.41 2015/06/16 04:26:23 jer Exp $
+
+*unidecode-0.04.18 (16 Jun 2015)
+
+ 16 Jun 2015; Jeroen Roovers <jer@gentoo.org> +unidecode-0.04.18.ebuild:
+ Version bump.
04 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add pypi to remote-id in metadata.xml
diff --git a/dev-python/unidecode/unidecode-0.04.18.ebuild b/dev-python/unidecode/unidecode-0.04.18.ebuild
new file mode 100644
index 000000000000..8a3c0b34115b
--- /dev/null
+++ b/dev-python/unidecode/unidecode-0.04.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unidecode/unidecode-0.04.18.ebuild,v 1.1 2015/06/16 04:26:23 jer Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+MY_PN=Unidecode
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="http://pypi.python.org/pypi/Unidecode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}