summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-28 18:14:10 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-28 18:14:10 +0000
commitb265da6a03e79f5dea011e5cb9f28f15645ebc92 (patch)
tree76bfe17483ed95eb6fd52cf3fb05e07b77109ef8 /dev-python/twistedsnmp
parentalpha/ia64/sparc stable wrt #281427 (diff)
downloadgentoo-2-b265da6a03e79f5dea011e5cb9f28f15645ebc92.tar.gz
gentoo-2-b265da6a03e79f5dea011e5cb9f28f15645ebc92.tar.bz2
gentoo-2-b265da6a03e79f5dea011e5cb9f28f15645ebc92.zip
Improve src_test().
(Portage version: 14914-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/twistedsnmp')
-rw-r--r--dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild b/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild
index 3a6b09c32957..d22f49382751 100644
--- a/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild
+++ b/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild,v 1.1 2009/11/28 17:54:40 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twistedsnmp/twistedsnmp-0.3.13.ebuild,v 1.2 2009/11/28 18:14:10 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -17,19 +17,25 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="test"
+IUSE=""
RDEPEND="=dev-python/pysnmp-3*
>=dev-python/twisted-1.3"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose )"
+DEPEND="${RDEPEND}"
RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable broken test.
+ sed -e "s/test_tableGetWithStart/_&/" -i test/test_get.py || die "sed failed"
+}
+
src_test() {
testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test.py
}
python_execute_function testing
}