summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-01 11:47:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-01 11:47:19 +0000
commit7ca1bd504bb3b36d1445604a5820e90bb02803cd (patch)
tree13c9f219afd9e89d4e909279f2b0ceb6b45f83b5 /dev-python/turbojson
parentBump to EAPI-2 to force sqlite deps so that tests have a chance of not failing (diff)
downloadgentoo-2-7ca1bd504bb3b36d1445604a5820e90bb02803cd.tar.gz
gentoo-2-7ca1bd504bb3b36d1445604a5820e90bb02803cd.tar.bz2
gentoo-2-7ca1bd504bb3b36d1445604a5820e90bb02803cd.zip
Bump to 1.1.4, fixes part of #264484
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/turbojson')
-rw-r--r--dev-python/turbojson/ChangeLog7
-rw-r--r--dev-python/turbojson/turbojson-1.1.4.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/turbojson/ChangeLog b/dev-python/turbojson/ChangeLog
index dfb45367f805..5fb3b9c2074f 100644
--- a/dev-python/turbojson/ChangeLog
+++ b/dev-python/turbojson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/turbojson
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/turbojson/ChangeLog,v 1.4 2009/01/08 23:37:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/turbojson/ChangeLog,v 1.5 2009/04/01 11:47:19 patrick Exp $
+
+*turbojson-1.1.4 (01 Apr 2009)
+
+ 01 Apr 2009; Patrick Lauer <patrick@gentoo.org> +turbojson-1.1.4.ebuild:
+ Bump to 1.1.4, fixes part of #264484
08 Jan 2009; Patrick Lauer <patrick@gentoo.org> -turbojson-1.0.ebuild,
-turbojson-1.1.2.ebuild:
diff --git a/dev-python/turbojson/turbojson-1.1.4.ebuild b/dev-python/turbojson/turbojson-1.1.4.ebuild
new file mode 100644
index 000000000000..15e666dd187a
--- /dev/null
+++ b/dev-python/turbojson/turbojson-1.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/turbojson/turbojson-1.1.4.ebuild,v 1.1 2009/04/01 11:47:19 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=TurboJson
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="TurboGears JSON file format support plugin"
+HOMEPAGE="http://www.turbogears.org/docs/plugins/template.html"
+#SRC_URI="http://files.turbogears.org/eggs/${MY_P}.tar.gz"
+SRC_URI="http://pypi.python.org/packages/source/T/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/ruledispatch
+ dev-python/simplejson"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+S=${WORKDIR}/${MY_P}
+
+src_test() {
+ PYTHONPATH=. "${python}" setup.py test || die "tests failed"
+}