summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-12 08:14:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-12 08:14:26 +0000
commitcd52cdd441782ab665500b97e28f1343ca7b4745 (patch)
treef6fc67c30841411ee8c8b5722f86961797cfb579 /dev-python/testrepository
parentAdd py34 (diff)
downloadgentoo-2-cd52cdd441782ab665500b97e28f1343ca7b4745.tar.gz
gentoo-2-cd52cdd441782ab665500b97e28f1343ca7b4745.tar.bz2
gentoo-2-cd52cdd441782ab665500b97e28f1343ca7b4745.zip
Add py34
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/testrepository')
-rw-r--r--dev-python/testrepository/ChangeLog8
-rw-r--r--dev-python/testrepository/testrepository-0.0.18-r1.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/testrepository/ChangeLog b/dev-python/testrepository/ChangeLog
index 76c473310799..3bb7106061a2 100644
--- a/dev-python/testrepository/ChangeLog
+++ b/dev-python/testrepository/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/testrepository
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testrepository/ChangeLog,v 1.10 2014/06/08 09:44:32 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testrepository/ChangeLog,v 1.11 2014/06/12 08:14:26 patrick Exp $
+
+*testrepository-0.0.18-r1 (12 Jun 2014)
+
+ 12 Jun 2014; Patrick Lauer <patrick@gentoo.org>
+ +testrepository-0.0.18-r1.ebuild:
+ Add py34
08 Jun 2014; Akinori Hattori <hattya@gentoo.org> testrepository-0.0.18.ebuild:
keyword ~ia64 wrt bug #508282
diff --git a/dev-python/testrepository/testrepository-0.0.18-r1.ebuild b/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
new file mode 100644
index 000000000000..a9707023ed5c
--- /dev/null
+++ b/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testrepository/testrepository-0.0.18-r1.ebuild,v 1.1 2014/06/12 08:14:26 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A repository of test results."
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/testresources[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+#bzr is listed but presumably req'd for a live repo test run
+RDEPEND=">=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]"
+
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ "${PYTHON}" ./testr init || die
+ "${PYTHON}" setup.py testr --coverage || die "tests failed under ${EPYTHON}"
+}