summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-11 21:44:34 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-11 21:44:34 +0000
commit8056d7c69cc5cc2249a5643d425073dca209a0d8 (patch)
tree342805a989832f250b194833b3aed4ab0b58c94e /dev-python/tagpy
parentVersion bump. (diff)
downloadgentoo-2-8056d7c69cc5cc2249a5643d425073dca209a0d8.tar.gz
gentoo-2-8056d7c69cc5cc2249a5643d425073dca209a0d8.tar.bz2
gentoo-2-8056d7c69cc5cc2249a5643d425073dca209a0d8.zip
bump, added py3 support
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/ChangeLog9
-rw-r--r--dev-python/tagpy/tagpy-2013.1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-python/tagpy/ChangeLog b/dev-python/tagpy/ChangeLog
index 6efb80139638..0ba1f9075809 100644
--- a/dev-python/tagpy/ChangeLog
+++ b/dev-python/tagpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/tagpy
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.51 2012/12/26 11:48:00 polynomial-c Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.52 2013/05/11 21:44:34 idella4 Exp $
+
+*tagpy-2013.1 (11 May 2013)
+
+ 11 May 2013; Ian Delaney <idella4@gentoo.org> +tagpy-2013.1.ebuild:
+ bump, added py3 support
26 Dec 2012; Lars Wendler <polynomial-c@gentoo.org> tagpy-0.94.8-r1.ebuild,
+files/tagpy-0.94.8-taglib-1.8_compat.patch:
diff --git a/dev-python/tagpy/tagpy-2013.1.ebuild b/dev-python/tagpy/tagpy-2013.1.ebuild
new file mode 100644
index 000000000000..33399877fbfa
--- /dev/null
+++ b/dev-python/tagpy/tagpy-2013.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/tagpy-2013.1.ebuild,v 1.1 2013/05/11 21:44:34 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Bindings for TagLib"
+HOMEPAGE="http://mathema.tician.de//software/tagpy http://pypi.python.org/pypi/tagpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/boost-1.49.0[python]
+ >=media-libs/taglib-1.7.2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_configure() {
+ "${PYTHON}" configure.py \
+ --taglib-inc-dir="${EPREFIX}/usr/include/taglib" \
+ --boost-python-libname="boost_python-${EPYTHON#python}"
+ distutils-r1_python_configure
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( test/* )
+
+ distutils-r1_python_install_all
+}