summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-03 23:29:09 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-03 23:29:09 +0000
commitaa69aa92f54c523aa051fdb208677bbc8dac2b9d (patch)
tree17e7fef3a67d9bea60805762bee2274b4f87b43d /dev-python/sphinx
parentVersion bump. (diff)
downloadgentoo-2-aa69aa92f54c523aa051fdb208677bbc8dac2b9d.tar.gz
gentoo-2-aa69aa92f54c523aa051fdb208677bbc8dac2b9d.tar.bz2
gentoo-2-aa69aa92f54c523aa051fdb208677bbc8dac2b9d.zip
Remove old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/ChangeLog6
-rw-r--r--dev-python/sphinx/sphinx-1.1.3-r3.ebuild121
-rw-r--r--dev-python/sphinx/sphinx-1.1.3-r5.ebuild117
-rw-r--r--dev-python/sphinx/sphinx-1.1.3-r6.ebuild126
-rw-r--r--dev-python/sphinx/sphinx-1.2.ebuild124
5 files changed, 5 insertions, 489 deletions
diff --git a/dev-python/sphinx/ChangeLog b/dev-python/sphinx/ChangeLog
index 405033ef53f7..5a71e4dfb25b 100644
--- a/dev-python/sphinx/ChangeLog
+++ b/dev-python/sphinx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/sphinx
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.160 2014/03/03 23:26:02 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.161 2014/03/03 23:29:09 radhermit Exp $
+
+ 03 Mar 2014; Tim Harder <radhermit@gentoo.org> -sphinx-1.1.3-r3.ebuild,
+ -sphinx-1.1.3-r5.ebuild, -sphinx-1.1.3-r6.ebuild, -sphinx-1.2.ebuild:
+ Remove old.
*sphinx-1.2.2 (03 Mar 2014)
diff --git a/dev-python/sphinx/sphinx-1.1.3-r3.ebuild b/dev-python/sphinx/sphinx-1.1.3-r3.ebuild
deleted file mode 100644
index d58f4cd84902..000000000000
--- a/dev-python/sphinx/sphinx-1.1.3-r3.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.1.3-r3.ebuild,v 1.10 2013/01/04 13:10:28 ago Exp $
-
-EAPI="4"
-PYTHON_DEPEND="*::3.2"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-PYTHON_TESTS_RESTRICTED_ABIS="2.5 *-pypy-*"
-
-inherit eutils distutils
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python documentation generator"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc latex"
-
-DEPEND=">=dev-python/docutils-0.7
- >=dev-python/jinja-2.3
- >=dev-python/pygments-1.2
- dev-python/setuptools
- latex? (
- dev-texlive/texlive-latexextra
- app-text/dvipng
- )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="CHANGES"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-python3.patch
- distutils_src_prepare
-
- prepare_tests() {
- mkdir -p build-${PYTHON_ABI}
- cp -r tests build-${PYTHON_ABI}/tests
- if [[ $(python_get_version -l --major) == "3" ]]; then
- 2to3-${PYTHON_ABI} -nw --no-diffs build-${PYTHON_ABI}/tests
- fi
- }
- use test && python_execute_function prepare_tests
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- sed -e "/import sys/a sys.path.insert(0, '${S}/build-$(PYTHON -f --ABI)/lib')" -i sphinx-build.py
- pushd doc > /dev/null
- emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- pushd build-${PYTHON_ABI} > /dev/null
- echo PYTHONPATH=lib nosetests --verbosity=1
- PYTHONPATH=lib nosetests --verbosity=1
- local rv=$?
- popd > /dev/null
- return $rv
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/sphinx-build"
-
- delete_grammar_pickle() {
- rm -f "${ED}$(python_get_sitedir)/sphinx/pycode/Grammar$(python_get_version -l).pickle"
- }
- python_execute_function -q delete_grammar_pickle
-
- if use doc; then
- dohtml -A txt -r doc/_build/html/* || die "Installation of documentation failed"
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- # Generate the Grammar pickle to avoid sandbox violations.
- generation_of_grammar_pickle() {
- "$(PYTHON)" -c "import sys; sys.path.insert(0, '${EROOT}$(python_get_sitedir -b)'); from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${EROOT}$(python_get_sitedir -b)/sphinx/pycode/Grammar.txt')"
- }
- python_execute_function \
- --action-message 'Generation of Grammar pickle with $(python_get_implementation_and_version)...' \
- --failure-message 'Generation of Grammar pickle with $(python_get_implementation_and_version) failed' \
- generation_of_grammar_pickle
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
-
- deletion_of_grammar_pickle() {
- rm -f "${EROOT}$(python_get_sitedir -b)/sphinx/pycode"/Grammar*.pickle || return 1
-
- # Delete empty parent directories.
- local dir="${EROOT}$(python_get_sitedir -b)/sphinx/pycode"
- while [[ "${dir}" != "${EROOT%/}" ]]; do
- rmdir "${dir}" 2> /dev/null || break
- dir="${dir%/*}"
- done
- }
- python_execute_function \
- --action-message 'Deletion of Grammar pickle with $(python_get_implementation_and_version)...' \
- --failure-message 'Deletion of Grammar pickle with $(python_get_implementation_and_version) failed' \
- deletion_of_grammar_pickle
-}
diff --git a/dev-python/sphinx/sphinx-1.1.3-r5.ebuild b/dev-python/sphinx/sphinx-1.1.3-r5.ebuild
deleted file mode 100644
index 741b19a502db..000000000000
--- a/dev-python/sphinx/sphinx-1.1.3-r5.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.1.3-r5.ebuild,v 1.8 2013/09/05 18:46:10 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1 versionator
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python documentation generator"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc latex test"
-
-RDEPEND=">=dev-python/docutils-0.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
- >=dev-python/pygments-1.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- latex? (
- dev-texlive/texlive-latexextra
- app-text/dvipng
- )"
-DEPEND="${DEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python3.patch
-)
-
-python_compile() {
- distutils-r1_python_compile
-
- # Generate the grammar. It will be caught by install somehow.
- # Note that the tests usually do it for us. However, I don't want
- # to trust USE=test really running all the tests, especially
- # with FEATURES=test-fail-continue.
- cd "${BUILD_DIR}"/lib || die
- "${PYTHON}" -m sphinx.pycode.__init__ \
- || die "Grammar generation failed."
-}
-
-python_compile_all() {
- use doc && emake -C doc SPHINXBUILD="${PYTHON} -m sphinx.__init__" html
-}
-
-python_test() {
- cp -r -l tests "${BUILD_DIR}"/ || die
-
- if [[ ${EPYTHON} == python3* ]]; then
- 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
- fi
-
- nosetests -w "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}
-
-replacing_python_eclass() {
- local pv
- for pv in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 1.1.3-r4 ${pv}; then
- return 0
- fi
- done
-
- return 1
-}
-
-pkg_preinst() {
- if replacing_python_eclass; then
- # the old python.eclass ebuild will want to remove our pickles...
- backup_pickle() {
- # array to enable filename expansion
- local pickle_name=(
- "${D}$(python_get_sitedir)"/sphinx/pycode/Grammar*.pickle
- )
-
- local dest=${ROOT}${pickle_name[0]#${D}}.backup
-
- cp -p -v "${pickle_name[0]}" "${dest}" \
- || die "Unable to backup grammar pickle from overwriting"
- }
-
- python_foreach_impl backup_pickle
- fi
-}
-
-pkg_postinst() {
- if replacing_python_eclass; then
- restore_pickle() {
- local backup_name=(
- "${ROOT}$(python_get_sitedir)"/sphinx/pycode/Grammar*.pickle.backup
- )
- local dest=${backup_name[0]%.backup}
-
- mv -v "${backup_name[0]}" "${dest}" \
- || die "Unable to restore grammar pickle backup"
- }
-
- python_foreach_impl restore_pickle
- fi
-}
diff --git a/dev-python/sphinx/sphinx-1.1.3-r6.ebuild b/dev-python/sphinx/sphinx-1.1.3-r6.ebuild
deleted file mode 100644
index d1fce0d2f633..000000000000
--- a/dev-python/sphinx/sphinx-1.1.3-r6.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.1.3-r6.ebuild,v 1.14 2013/09/05 18:46:10 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1 eutils versionator
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python documentation generator"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc latex test"
-
-RDEPEND=">=dev-python/docutils-0.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
- >=dev-python/pygments-1.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- latex? (
- dev-texlive/texlive-latexextra
- app-text/dvipng
- )"
-DEPEND="${DEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-python3.patch
- "${FILESDIR}"/${P}-docutils-manpage.patch
-)
-
-python_compile() {
- distutils-r1_python_compile
-
- # Generate the grammar. It will be caught by install somehow.
- # Note that the tests usually do it for us. However, I don't want
- # to trust USE=test really running all the tests, especially
- # with FEATURES=test-fail-continue.
- cd "${BUILD_DIR}"/lib || die
- "${PYTHON}" -m sphinx.pycode.__init__ \
- || die "Grammar generation failed."
-}
-
-python_compile_all() {
- use doc && emake -C doc SPHINXBUILD="${PYTHON} -m sphinx.__init__" html
-}
-
-python_test() {
- cp -r -l tests "${BUILD_DIR}"/ || die
-
- if [[ ${EPYTHON} == python3* ]]; then
- 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
- fi
-
- nosetests -w "${BUILD_DIR}"/tests \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}
-
-replacing_python_eclass() {
- local pv
- for pv in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 1.1.3-r4 ${pv}; then
- return 0
- fi
- done
-
- return 1
-}
-
-pkg_preinst() {
- if replacing_python_eclass; then
- # the old python.eclass ebuild will want to remove our pickles...
- backup_pickle() {
- # array to enable filename expansion
- local pickle_name=(
- "${D}$(python_get_sitedir)"/sphinx/pycode/Grammar*.pickle
- )
-
- local dest=${ROOT}${pickle_name[0]#${D}}.backup
-
- eumask_push 022
- mkdir -p "${dest%/*}" || die
- eumask_pop
-
- cp -p -v "${pickle_name[0]}" "${dest}" \
- || die "Unable to backup grammar pickle from overwriting"
- }
-
- python_foreach_impl backup_pickle
- fi
-}
-
-pkg_postinst() {
- if replacing_python_eclass; then
- local warned
-
- restore_pickle() {
- local backup_name=(
- "${ROOT}$(python_get_sitedir)"/sphinx/pycode/Grammar*.pickle.backup
- )
- local dest=${backup_name[0]%.backup}
-
- mv -v "${backup_name[0]}" "${dest}" \
- || die "Unable to restore grammar pickle backup"
- }
-
- python_foreach_impl restore_pickle
-
- [[ ${warned} ]] && ewarn "Please try rebuilding the package."
- fi
-}
diff --git a/dev-python/sphinx/sphinx-1.2.ebuild b/dev-python/sphinx/sphinx-1.2.ebuild
deleted file mode 100644
index 5cc129cb0c8f..000000000000
--- a/dev-python/sphinx/sphinx-1.2.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.2.ebuild,v 1.2 2014/01/22 13:19:53 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1 eutils versionator
-
-MY_PN="Sphinx"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python documentation generator"
-HOMEPAGE="http://sphinx.pocoo.org/ http://pypi.python.org/pypi/Sphinx"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc latex test"
-
-# Split the jinja dep to allow different slots to satisfy it
-RDEPEND="
- >=dev-python/docutils-0.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.3[$(python_gen_usedep python3_2)]
- >=dev-python/jinja-2.3[$(python_gen_usedep python{2_6,2_7,3_3} 'pypy*')]
- >=dev-python/pygments-1.2[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- latex? (
- dev-texlive/texlive-latexextra
- app-text/dvipng
- )"
-DEPEND="${DEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile() {
- distutils-r1_python_compile
-
- # Generate the grammar. It will be caught by install somehow.
- # Note that the tests usually do it for us. However, I don't want
- # to trust USE=test really running all the tests, especially
- # with FEATURES=test-fail-continue.
- cd "${BUILD_DIR}"/lib || die
- "${PYTHON}" -m sphinx.pycode.__init__ \
- || die "Grammar generation failed."
-}
-
-python_compile_all() {
- use doc && emake -C doc SPHINXBUILD="${PYTHON} -m sphinx.__init__" html
-}
-
-python_test() {
- cp -r -l tests "${BUILD_DIR}"/ || die
-
- if $(python_is_python3); then
- 2to3 -w --no-diffs "${BUILD_DIR}"/tests || die
- fi
-
- nosetests -w "${BUILD_DIR}"/tests -v \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}
-
-replacing_python_eclass() {
- local pv
- for pv in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 1.1.3-r4 ${pv}; then
- return 0
- fi
- done
-
- return 1
-}
-
-pkg_preinst() {
- if replacing_python_eclass; then
- # the old python.eclass ebuild will want to remove our pickles...
- backup_pickle() {
- # array to enable filename expansion
- local pickle_name=(
- "${D}$(python_get_sitedir)"/sphinx/pycode/Grammar*.pickle
- )
-
- local dest=${ROOT}${pickle_name[0]#${D}}.backup
-
- eumask_push 022
- mkdir -p "${dest%/*}" || die
- eumask_pop
-
- cp -p -v "${pickle_name[0]}" "${dest}" \
- || die "Unable to backup grammar pickle from overwriting"
- }
-
- python_foreach_impl backup_pickle
- fi
-}
-
-pkg_postinst() {
- if replacing_python_eclass; then
- local warned
-
- restore_pickle() {
- local backup_name=(
- "${ROOT}$(python_get_sitedir)"/sphinx/pycode/Grammar*.pickle.backup
- )
- local dest=${backup_name[0]%.backup}
-
- mv -v "${backup_name[0]}" "${dest}" \
- || die "Unable to restore grammar pickle backup"
- }
-
- python_foreach_impl restore_pickle
-
- [[ ${warned} ]] && ewarn "Please try rebuilding the package."
- fi
-}