summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-16 02:39:07 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-16 02:39:07 +0000
commitbc303cded33d7e46fa5402bbee865bf110e25410 (patch)
tree702e90d559e0fdce910b5918943e026fadfed02d /dev-python/socketpool/socketpool-0.5.2.ebuild
parentBump for #442946 (diff)
downloadgentoo-2-bc303cded33d7e46fa5402bbee865bf110e25410.tar.gz
gentoo-2-bc303cded33d7e46fa5402bbee865bf110e25410.tar.bz2
gentoo-2-bc303cded33d7e46fa5402bbee865bf110e25410.zip
New ebuild written by me, required as a dep to restkit in test suite wrt Bug #41665
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/socketpool/socketpool-0.5.2.ebuild')
-rw-r--r--dev-python/socketpool/socketpool-0.5.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/socketpool/socketpool-0.5.2.ebuild b/dev-python/socketpool/socketpool-0.5.2.ebuild
new file mode 100644
index 000000000000..b0ed9939840d
--- /dev/null
+++ b/dev-python/socketpool/socketpool-0.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/socketpool/socketpool-0.5.2.ebuild,v 1.1 2012/11/16 02:39:07 idella4 Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.5 3.*"
+inherit distutils
+
+DESCRIPTION="A simple Python socket pool"
+HOMEPAGE="http://github.com/benoitc/socketpool/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+IUSE="examples"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/gevent"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples
+ insinto usr/share/doc/${P}
+ doins -r examples/
+ fi
+}