summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-09-08 23:09:14 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-09-08 23:09:14 +0000
commit73a6f61e0499970603e38c310d3d04f50f379899 (patch)
treead45c959db9a0b45d779730e76da865d11238c7d /dev-python/sip
parentVersion bump. Remove old ebuilds (diff)
downloadgentoo-2-73a6f61e0499970603e38c310d3d04f50f379899.tar.gz
gentoo-2-73a6f61e0499970603e38c310d3d04f50f379899.tar.bz2
gentoo-2-73a6f61e0499970603e38c310d3d04f50f379899.zip
Version bump. Remove old ebuilds
(Portage version: 2.2_rc77/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog9
-rw-r--r--dev-python/sip/sip-4.10.1.ebuild73
-rw-r--r--dev-python/sip/sip-4.10.3.ebuild73
-rw-r--r--dev-python/sip/sip-4.11.1.ebuild (renamed from dev-python/sip/sip-4.10.5.ebuild)2
-rw-r--r--dev-python/sip/sip-4.8.2-r1.ebuild75
5 files changed, 9 insertions, 223 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index af9bbf011074..3e352a111842 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.171 2010/09/01 08:58:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.172 2010/09/08 23:09:14 hwoarang Exp $
+
+*sip-4.11.1 (08 Sep 2010)
+
+ 08 Sep 2010; Markos Chandras <hwoarang@gentoo.org> -sip-4.8.2-r1.ebuild,
+ -sip-4.10.1.ebuild, -sip-4.10.3.ebuild, -sip-4.10.5.ebuild,
+ +sip-4.11.1.ebuild:
+ Version bump. Remove old ebuilds
*sip-4.11 (01 Sep 2010)
diff --git a/dev-python/sip/sip-4.10.1.ebuild b/dev-python/sip/sip-4.10.1.ebuild
deleted file mode 100644
index 3508639e87b5..000000000000
--- a/dev-python/sip/sip-4.10.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.10.1.ebuild,v 1.2 2010/07/06 18:41:15 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils python toolchain-funcs
-
-MY_P=${P/_pre/-snapshot-}
-
-DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --bindir=${EPREFIX}/usr/bin
- --destdir=${EPREFIX}$(python_get_sitedir)
- --incdir=${EPREFIX}$(python_get_includedir)
- --sipdir=${EPREFIX}/usr/share/sip
- $(use debug && echo '--debug')
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
- LFLAGS='${LDFLAGS}'
- STRIP=true"
- echo ${myconf}
- eval ${myconf}
- }
- python_execute_function -s configuration
-}
-
-src_install() {
- python_src_install
-
- dodoc NEWS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn 'When updating sip, you usually need to recompile packages that'
- ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
- ewarn 'app-portage/gentoolkit installed you can find these packages with'
- ewarn '`equery d sip` and `equery d PyQt4`.'
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}
diff --git a/dev-python/sip/sip-4.10.3.ebuild b/dev-python/sip/sip-4.10.3.ebuild
deleted file mode 100644
index 171d2ca6361b..000000000000
--- a/dev-python/sip/sip-4.10.3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.10.3.ebuild,v 1.1 2010/07/13 08:09:38 hwoarang Exp $
-
-EAPI="2"
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils python toolchain-funcs
-
-MY_P=${P/_pre/-snapshot-}
-
-DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro http://pypi.python.org/pypi/SIP"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}${PV%%.*}/${MY_P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 sip )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.9.3-darwin.patch
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --bindir=${EPREFIX}/usr/bin
- --destdir=${EPREFIX}$(python_get_sitedir)
- --incdir=${EPREFIX}$(python_get_includedir)
- --sipdir=${EPREFIX}/usr/share/sip
- $(use debug && echo '--debug')
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
- LFLAGS='${LDFLAGS}'
- STRIP=true"
- echo ${myconf}
- eval ${myconf}
- }
- python_execute_function -s configuration
-}
-
-src_install() {
- python_src_install
-
- dodoc NEWS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
-
- ewarn 'When updating sip, you usually need to recompile packages that'
- ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
- ewarn 'app-portage/gentoolkit installed you can find these packages with'
- ewarn '`equery d sip` and `equery d PyQt4`.'
-}
-
-pkg_postrm() {
- python_mod_cleanup sipconfig.py sipdistutils.py
-}
diff --git a/dev-python/sip/sip-4.10.5.ebuild b/dev-python/sip/sip-4.11.1.ebuild
index 8362fe14d22e..c7b9a591f414 100644
--- a/dev-python/sip/sip-4.10.5.ebuild
+++ b/dev-python/sip/sip-4.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.10.5.ebuild,v 1.1 2010/07/16 15:44:45 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.11.1.ebuild,v 1.1 2010/09/08 23:09:14 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="*"
diff --git a/dev-python/sip/sip-4.8.2-r1.ebuild b/dev-python/sip/sip-4.8.2-r1.ebuild
deleted file mode 100644
index 6db1c6dc66e5..000000000000
--- a/dev-python/sip/sip-4.8.2-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.8.2-r1.ebuild,v 1.5 2010/07/06 18:41:15 arfrever Exp $
-
-EAPI="2"
-PYTHON_DEPEND="*"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils python toolchain-funcs
-
-MY_P=${P/_pre/-snapshot-}
-
-DESCRIPTION="A tool for generating bindings for C++ classes so that they can be used by Python"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/sip/intro"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-
-LICENSE="sip"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND=""
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-python-3.patch"
- python_copy_sources
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --incdir=$(python_get_includedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
- LFLAGS='${LDFLAGS}'
- STRIP=true"
- echo ${myconf}
- eval ${myconf}
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_install() {
- python_execute_function -d -s
-
- dodoc ChangeLog NEWS || die
-
- if use doc; then
- dohtml -r doc/html/* || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize sipconfig.py sipdistutils.py
- ewarn 'When updating sip, you usually need to recompile packages that'
- ewarn 'depend on sip, such as PyQt4 and qscintilla-python. If you have'
- ewarn 'app-portage/gentoolkit installed you can find these packages with'
- ewarn '`equery d sip` and `equery d PyQt4`.'
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}