summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-31 20:31:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-31 20:31:12 +0000
commita5dfdb0799c8c3476cf1ea41e153cf00b86070bc (patch)
treea1445e0ecd6cc47000d6b5bf3d75d4b27c767ef8 /dev-python/simplejson
parentStable for HPPA (bug #344827). (diff)
downloadgentoo-2-a5dfdb0799c8c3476cf1ea41e153cf00b86070bc.tar.gz
gentoo-2-a5dfdb0799c8c3476cf1ea41e153cf00b86070bc.tar.bz2
gentoo-2-a5dfdb0799c8c3476cf1ea41e153cf00b86070bc.zip
Improve support for Jython in src_test().
(Portage version: 2.2.0_alpha11_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/simplejson-2.1.2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/simplejson/simplejson-2.1.2.ebuild b/dev-python/simplejson/simplejson-2.1.2.ebuild
index b037da83e78b..be3b47bd9fad 100644
--- a/dev-python/simplejson/simplejson-2.1.2.ebuild
+++ b/dev-python/simplejson/simplejson-2.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.1.2.ebuild,v 1.3 2010/12/13 16:05:46 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/simplejson/simplejson-2.1.2.ebuild,v 1.4 2010/12/31 20:31:12 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -25,7 +25,9 @@ PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
src_test() {
testing() {
- ln -fs ../$(ls -d build-${PYTHON_ABI}/lib*)/simplejson/_speedups.so simplejson/_speedups.so
+ if [[ "$(python_get_implementation)" != "Jython" ]]; then
+ ln -fs ../$(ls -d build-${PYTHON_ABI}/lib*)/simplejson/_speedups.so simplejson/_speedups.so || return 1
+ fi
PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" simplejson/tests/__init__.py
}
python_execute_function testing