summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-09-08 21:49:52 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-09-08 21:49:52 +0000
commitc749cc3c90069188ebe515353ac7c0b20c48dc22 (patch)
tree7f8d0b2cebee8d51613a5163efb2ea8d2b372416 /dev-python/shiboken
parentfix various compilation issues thanks to Arfrever (diff)
downloadgentoo-2-c749cc3c90069188ebe515353ac7c0b20c48dc22.tar.gz
gentoo-2-c749cc3c90069188ebe515353ac7c0b20c48dc22.tar.bz2
gentoo-2-c749cc3c90069188ebe515353ac7c0b20c48dc22.zip
Version bump.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/shiboken')
-rw-r--r--dev-python/shiboken/ChangeLog8
-rw-r--r--dev-python/shiboken/shiboken-1.1.2.ebuild94
2 files changed, 100 insertions, 2 deletions
diff --git a/dev-python/shiboken/ChangeLog b/dev-python/shiboken/ChangeLog
index 370b31d52a4c..04c2a012d26a 100644
--- a/dev-python/shiboken/ChangeLog
+++ b/dev-python/shiboken/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/shiboken
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.31 2012/07/27 21:31:46 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/ChangeLog,v 1.32 2012/09/08 21:49:52 pesa Exp $
+
+*shiboken-1.1.2 (08 Sep 2012)
+
+ 08 Sep 2012; Davide Pesavento <pesa@gentoo.org> +shiboken-1.1.2.ebuild:
+ Version bump.
27 Jul 2012; Steev Klimaszewski <steev@gentoo.org> shiboken-1.1.1.ebuild:
Add ~arm keyword. Tested on i.MX6 (armv7)
@@ -150,4 +155,3 @@
+metadata.xml:
Initial ebuild for shiboken. Replaces dev-python/boostpythongenerator for
>=pyside-0.3.2
-
diff --git a/dev-python/shiboken/shiboken-1.1.2.ebuild b/dev-python/shiboken/shiboken-1.1.2.ebuild
new file mode 100644
index 000000000000..b6089f1c4361
--- /dev/null
+++ b/dev-python/shiboken/shiboken-1.1.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/shiboken/shiboken-1.1.2.ebuild,v 1.1 2012/09/08 21:49:51 pesa Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.1 *-jython 2.7-pypy-*"
+
+inherit multilib cmake-utils python
+
+DESCRIPTION="A tool for creating Python bindings for C++ libraries"
+HOMEPAGE="http://www.pyside.org/"
+SRC_URI="http://www.pyside.org/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.6.32
+ >=dev-libs/libxslt-1.1.19
+ >=x11-libs/qt-core-4.7.0:4
+ >=x11-libs/qt-xmlpatterns-4.7.0:4
+ !dev-python/apiextractor
+ !dev-python/generatorrunner
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=x11-libs/qt-gui-4.7.0:4
+ >=x11-libs/qt-test-4.7.0:4
+ )"
+
+DOCS=( AUTHORS ChangeLog )
+
+src_prepare() {
+ # Fix inconsistent naming of libshiboken.so and ShibokenConfig.cmake,
+ # caused by the usage of a different version suffix with python >= 3.2
+ sed -i -e "/get_config_var('SOABI')/d" \
+ cmake/Modules/FindPython3InterpWithDebug.cmake || die
+
+ if use prefix; then
+ cp "${FILESDIR}"/rpath.cmake .
+ sed \
+ -i '1iinclude(rpath.cmake)' \
+ CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ configuration() {
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="$(PYTHON -a)"
+ -DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
+ -DPYTHON_SUFFIX="-python${PYTHON_ABI}"
+ $(cmake-utils_use_build test TESTS)
+ )
+
+ if [[ $(python_get_version -l --major) == 3 ]]; then
+ mycmakeargs+=(
+ -DUSE_PYTHON3=ON
+ -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON3_LIBRARY="$(python_get_library)"
+ )
+ fi
+
+ CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_configure
+ }
+ python_execute_function configuration
+}
+
+src_compile() {
+ compilation() {
+ CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_make
+ }
+ python_execute_function compilation
+}
+
+src_test() {
+ testing() {
+ CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_test
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ installation() {
+ CMAKE_BUILD_DIR="${S}_${PYTHON_ABI}" cmake-utils_src_install
+ mv "${ED}"usr/$(get_libdir)/pkgconfig/${PN}{,-python${PYTHON_ABI}}.pc || die
+ }
+ python_execute_function installation
+}